@fastify/static vulnerable to path traversal in directory listing
CVE-2026-6410GHSA-pr96-94w5-mx2h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/static 9.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @fastify/static
- Affected
- >= 8.0.0, <= 9.1.0
- Fixed in
- 9.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pr96-94w5-mx2h lists affected ranges: npm @fastify/static >=8.0.0 <9.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pr96-94w5-mx2h lists affected ranges: npm @fastify/static >=8.0.0 <=9.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-6410: 0.51% estimated exploitation activity in the next 30 days; percentile 43.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact @fastify/static v9.1.0 and earlier serves directory listings outside the configured static root when the list option is enabled. A request such as /public/../outside/ causes dirList.path() to resolve a directory outside the root via path.join() without a containment check. A remote unauthenticated attacker can obtain directory listings for arbitrary directories accessible to the Node.js process, disclosing directory names and filenames that should not be exposed. File contents are not disclosed. Patches Upgrade to @fastify/static = 9.1.1. Workarounds Disable directory listing by removing the list option from the plugin configuration.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pr96-94w5-mx2h
- Revision 1 · created ·
Published from osv record GHSA-pr96-94w5-mx2h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-6410 Advisory: @fastify/static vulnerable to path traversal in directory listing IDs: CVE-2026-6410, GHSA-pr96-94w5-mx2h Record: https://patchnext.com/advisories/cve-2026-6410 (revision 2, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fastify/static 9.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fastify/static: affected >= 8.0.0, <= 9.1.0; fixed in 9.1.1 ## Suggested inspection (read-only) - `npm ls @fastify/static --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fastify/static. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pr96-94w5-mx2h (OSV record GHSA-pr96-94w5-mx2h lists affected ranges: npm @fastify/static >=8.0.0 <9.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-pr96-94w5-mx2h (GitHub-reviewed advisory GHSA-pr96-94w5-mx2h lists affected ranges: npm @fastify/static >=8.0.0 <=9.1.0) Commands are suggestions: review each one before running it.
Loading voting…