SurrealDB: Scraping a TABLE with no available PERMISSIONS to current auth level
CVE-2026-63755GHSA-98fx-66cf-fc7c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 3.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io surrealdb
- Affected
- < 3.1.0
- Fixed in
- 3.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-98fx-66cf-fc7c lists affected ranges: crates.io surrealdb >=0 <3.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-63755: 0.36% estimated exploitation activity in the next 30 days; percentile 29.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was discovered where the user-supplied WHERE clause in a SELECT statement is evaluated against the full record data before PERMISSIONS FOR SELECT WHERE determines whether the principal is authorised to access that record. A side-effecting expression in the WHERE clause can exfiltrate record contents before the permission check runs. The same ordering bug affects the SET, MERGE, CONTENT and PATCH clauses of update-variant statements (UPDATE, UPSERT-update, INSERT ON DUPLICATE KEY UPDATE, RELATE-update). This vulnerability is confined to the attacker's current database. It does not cross namespace or database isolation boundaries. Impact An authenticated user — including Record and Scope users — can read the full contents of any table in the database they are authenticated against, bypassing PERMISSIONS FOR SELECT WHERE restrictions on those tables. The most direct exfiltration method requires scripting functions to be enabled (--allow-scripting / -A). However,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-98fx-66cf-fc7c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-63755 Advisory: SurrealDB: Scraping a TABLE with no available PERMISSIONS to current auth level IDs: CVE-2026-63755, GHSA-98fx-66cf-fc7c Record: https://patchnext.com/advisories/cve-2026-63755 (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: surrealdb 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io surrealdb: affected < 3.1.0; fixed in 3.1.0 ## Suggested inspection (read-only) - crates.io surrealdb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on surrealdb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-98fx-66cf-fc7c (GitHub-reviewed advisory GHSA-98fx-66cf-fc7c lists affected ranges: crates.io surrealdb >=0 <3.1.0) Commands are suggestions: review each one before running it.
Loading voting…