Skip to content

← Actionable
Medium, CVSS 6.5amended

SurrealDB: Array element-level (field.*) SELECT permissions leak denied elements to record users

CVE-2026-63740GHSA-8rw6-p7m8-63jp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 3.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io surrealdb

    Affected
    <= 3.1.3
    Fixed in
    3.1.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-63740: 0.36% estimated exploitation activity in the next 30 days; percentile 29.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A SELECT permission defined on an array element (DEFINE FIELD field. … PERMISSIONS FOR select …) is not enforced correctly for RECORD users. Instead of hiding the denied elements, the query leaks a subset of them: a deny-all returns the odd-indexed elements, and a per-element predicate keeps and drops the wrong ones. The filter removed each denied element by index while walking the array forwards. Because removing an element shifts every later index down, each cut invalidated the indices still pending in the loop, leaving denied elements behind. Field-level permissions are enforced correctly; only the element (field.) level is affected, and only for record users — root and record-owner sessions are not. Impact What an attacker can do: - As a record (scope) user, read array elements that an element-level (field.) SELECT permission should hide, on any table they can already SELECT. - Recover denied elements through both a deny-all and a WHERE predicate — the wrong elements are selected…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8rw6-p7m8-63jp

  2. Revision 1 · created ·

    Published from osv record GHSA-8rw6-p7m8-63jp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63740

Advisory: SurrealDB: Array element-level (field.*) SELECT permissions leak denied elements to record users
IDs: CVE-2026-63740, GHSA-8rw6-p7m8-63jp
Record: https://patchnext.com/advisories/cve-2026-63740 (revision 2, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: surrealdb 3.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io surrealdb: affected <= 3.1.3; fixed in 3.1.4

## Suggested inspection (read-only)
- crates.io surrealdb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on surrealdb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8rw6-p7m8-63jp (OSV record GHSA-8rw6-p7m8-63jp lists affected ranges: crates.io surrealdb >=0 <3.1.4 (fixed))
- Verified: https://github.com/advisories/GHSA-8rw6-p7m8-63jp (GitHub-reviewed advisory GHSA-8rw6-p7m8-63jp lists affected ranges: crates.io surrealdb >=0 <=3.1.3)

Commands are suggestions: review each one before running it.

Loading voting…