Skip to content

← Actionable
Medium, CVSS 4.3amended

SurrealDB: Writes in a PERMISSIONS clause bypass table permissions

CVE-2026-63733GHSA-66r2-5gwj-gxm2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb-core 3.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-63733: 0.29% estimated exploitation activity in the next 30 days; percentile 21.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A PERMISSIONS ... WHERE clause is evaluated with permission enforcement disabled, so it can't recurse into its own checks. But the clause could also contain data-modifying statements, and these ran with enforcement still off — so evaluating a permission check could write to tables the caller cannot write. For example: Any user allowed to update a post now also creates a log record, even with no permission on log. The clause is evaluated once per matched record, so one statement can cause several writes. Impact Only databases with a PERMISSIONS clause that contains a write are affected; FULL, NONE, and read-only clauses are not. What an attacker can do: - With permission to perform the guarded operation (a low-privileged or record user is enough), write to tables in their own database that their permissions would otherwise forbid, by triggering an operation the clause guards. - Cause several writes from a single statement — the clause is evaluated once per matched record. - Trigger…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-66r2-5gwj-gxm2

  2. Revision 1 · created ·

    Published from osv record GHSA-66r2-5gwj-gxm2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63733

Advisory: SurrealDB: Writes in a PERMISSIONS clause bypass table permissions
IDs: CVE-2026-63733, GHSA-66r2-5gwj-gxm2
Record: https://patchnext.com/advisories/cve-2026-63733 (revision 2, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: surrealdb-core 3.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io surrealdb-core: affected < 3.2.0; fixed in 3.2.0

## Suggested inspection (read-only)
- crates.io surrealdb-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on surrealdb-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-66r2-5gwj-gxm2 (OSV record GHSA-66r2-5gwj-gxm2 lists affected ranges: crates.io surrealdb-core >=0 <3.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-66r2-5gwj-gxm2 (GitHub-reviewed advisory GHSA-66r2-5gwj-gxm2 lists affected ranges: crates.io surrealdb-core >=0 <3.2.0)

Commands are suggestions: review each one before running it.

Loading voting…