Drupal core allows Cross-Site Scripting (XSS)
CVE-2026-6367GHSA-pw6f-3999-xp7g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 11.3.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/core
- Affected
- >= 11.3.0, < 11.3.7
- Fixed in
- 11.3.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pw6f-3999-xp7g lists affected ranges: Packagist drupal/core >=11.3.0 <11.3.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-6367: 0.20% estimated exploitation activity in the next 30 days; percentile 10.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS). This issue affects Drupal core: from 11.3.0 before 11.3.7.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pw6f-3999-xp7g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-6367 Advisory: Drupal core allows Cross-Site Scripting (XSS) IDs: CVE-2026-6367, GHSA-pw6f-3999-xp7g Record: https://patchnext.com/advisories/cve-2026-6367 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/core 11.3.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/core: affected >= 11.3.0, < 11.3.7; fixed in 11.3.7 ## Suggested inspection (read-only) - Packagist drupal/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pw6f-3999-xp7g (GitHub-reviewed advisory GHSA-pw6f-3999-xp7g lists affected ranges: Packagist drupal/core >=11.3.0 <11.3.7) Commands are suggestions: review each one before running it.
Loading voting…