Skip to content

← Actionable
Medium, CVSS 6.6

Drupal core allows Object Injection

CVE-2026-6366GHSA-xmjc-63pr-2mpg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 11.3.7, 11.2.11, 10.6.7, 10.5.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.0.0, < 10.5.9>= 10.6.0, < 10.6.7>= 11.0.0, < 11.2.11>= 11.3.0, < 11.3.7
    Fixed in
    11.2.11, 10.6.7, 10.5.9, 11.3.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-6366: 0.40% estimated exploitation activity in the next 30 days; percentile 34.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection. This issue affects Drupal core: from 8.0.0 before 10.5.9, from 10.6.0 before 10.6.7, from 11.0.0 before 11.2.11, from 11.3.0 before 11.3.7.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xmjc-63pr-2mpg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-6366

Advisory: Drupal core allows Object Injection
IDs: CVE-2026-6366, GHSA-xmjc-63pr-2mpg
Record: https://patchnext.com/advisories/cve-2026-6366 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 11.3.7, 11.2.11, 10.6.7, 10.5.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.0.0, < 10.5.9; >= 10.6.0, < 10.6.7; >= 11.0.0, < 11.2.11; >= 11.3.0, < 11.3.7; fixed in 11.2.11, 10.6.7, 10.5.9, 11.3.7

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xmjc-63pr-2mpg (GitHub-reviewed advisory GHSA-xmjc-63pr-2mpg lists affected ranges: Packagist drupal/core >=8.0.0 =10.6.0 =11.0.0 =11.3.0 <11.3.7)

Commands are suggestions: review each one before running it.

Loading voting…