Skip to content

← Actionable
Low, CVSS 3.3amended

ONNX: Heap-Buffer-Overflow READ in Gemm Version Converter Adapter via Undersized Input Shape

CVE-2026-63632GHSA-p893-rvq9-2xf9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (onnx 1.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI onnx

    Affected
    >= 1.3.0, <= 1.21.0
    Fixed in
    1.22.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-63632: 0.17% estimated exploitation activity in the next 30 days; percentile 6.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Heap-buffer-overflow READ (16 bytes) in Gemm76::adaptgemm76() (onnx/versionconverter/adapters/gemm76.h:41) when ConvertVersion() processes a model with a Gemm node whose input tensors have fewer than 2 dimensions. The adapter accesses Bshape[1] without checking rank. On Release builds the OOB read is silent; ASan confirms 16-byte read past a 48-byte allocation. Details The Gemm 7→6 downgrade adapter reads input shapes without bounds checking: The PoC has input B with shape [28] (1 dimension). Bshape has 1 element. Accessing Bshape[1] reads 16 bytes past the std::vector<Dimension internal storage into adjacent heap memory. The same unchecked pattern applies to Ashape[0] and Ashape[1] at lines 34 and 36. Entry point: onnx.versionconverter.convertversion(model, 6) — different from the InferShapes bugs reported in separate advisories. This triggers during opset downgrade (7→6). PoC 186-byte PoC. ASan confirms: heap-buffer-overflow READ of size 16 at gemm76.h:41, 0 bytes after…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p893-rvq9-2xf9

  2. Revision 1 · created ·

    Published from osv record GHSA-p893-rvq9-2xf9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63632

Advisory: ONNX: Heap-Buffer-Overflow READ in Gemm Version Converter Adapter via Undersized Input Shape
IDs: CVE-2026-63632, GHSA-p893-rvq9-2xf9
Record: https://patchnext.com/advisories/cve-2026-63632 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: onnx 1.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI onnx: affected >= 1.3.0, <= 1.21.0; fixed in 1.22.0

## Suggested inspection (read-only)
- `python -m pip show onnx`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on onnx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p893-rvq9-2xf9 (OSV record GHSA-p893-rvq9-2xf9 lists affected ranges: PyPI onnx >=1.3.0 <1.22.0 (fixed))
- Verified: https://github.com/advisories/GHSA-p893-rvq9-2xf9 (GitHub-reviewed advisory GHSA-p893-rvq9-2xf9 lists affected ranges: PyPI onnx >=1.3.0 <=1.21.0)

Commands are suggestions: review each one before running it.

Loading voting…