pip Vulnerable to Inclusion of Functionality from Untrusted Control Sphere
CVE-2026-6357GHSA-jp4c-xjxw-mgf9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pip 26.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pip
- Affected
- < 26.1
- Fixed in
- 26.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jp4c-xjxw-mgf9 lists affected ranges: PyPI pip >=0 <26.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jp4c-xjxw-mgf9 lists affected ranges: PyPI pip >=0 <26.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-6357: 0.14% estimated exploitation activity in the next 30 days; percentile 3.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
pip prior to version 26.1 would run self-update check functionality after installing wheel files which required importing well-known Python modules names. These module imports were intentionally deferred to increase startup time of the pip CLI. The patch changes self-update functionality to run before wheels are installed to prevent newly-installed modules from being imported shortly after the installation of a wheel package. Users should still review package contents prior to installation.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jp4c-xjxw-mgf9
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jp4c-xjxw-mgf9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-6357 Advisory: pip Vulnerable to Inclusion of Functionality from Untrusted Control Sphere IDs: CVE-2026-6357, GHSA-jp4c-xjxw-mgf9 Record: https://patchnext.com/advisories/cve-2026-6357 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pip 26.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pip: affected < 26.1; fixed in 26.1 ## Suggested inspection (read-only) - `python -m pip show pip`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pip. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jp4c-xjxw-mgf9 (OSV record GHSA-jp4c-xjxw-mgf9 lists affected ranges: PyPI pip >=0 <26.1 (fixed)) - Verified: https://github.com/advisories/GHSA-jp4c-xjxw-mgf9 (GitHub-reviewed advisory GHSA-jp4c-xjxw-mgf9 lists affected ranges: PyPI pip >=0 <26.1) Commands are suggestions: review each one before running it.
Loading voting…