Snipe-IT: Stored XSS via Inline XML Rendering in the Uploaded Files API
CVE-2026-63498GHSA-396x-xmvh-p563
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (snipe/snipe-it 8.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist snipe/snipe-it
- Affected
- < 8.7.0
- Fixed in
- 8.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-396x-xmvh-p563 lists affected ranges: Packagist snipe/snipe-it >=0 <8.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-63498: 0.24% estimated exploitation activity in the next 30 days; percentile 15.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Snipe-IT's uploaded-files API accepts XML documents and later serves them inline without applying the safe-inline allowlist used by the equivalent web controller. An authenticated user who can attach files to a supported object can upload an XSLT stylesheet and an XML document that references it through xml-stylesheet. When another authorized user opens the XML file through the API with ?inline=true, the browser applies the attacker-controlled stylesheet, which produces HTML containing JavaScript in the Snipe-IT origin. This was reproduced against commit df8e3b144331d0c1cc14778f900e7646d1d9a509 (v8.6.3-231-gdf8e3b1443). The attack requires an authenticated account with file access to at least one supported object and one victim interaction. Scope changes because attacker-controlled code executes in another user's Snipe-IT security context. The script can read same-origin data available to the victim and perform authenticated actions as that victim. Affected Components -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-396x-xmvh-p563
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-63498 Advisory: Snipe-IT: Stored XSS via Inline XML Rendering in the Uploaded Files API IDs: CVE-2026-63498, GHSA-396x-xmvh-p563 Record: https://patchnext.com/advisories/cve-2026-63498 (revision 1, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: snipe/snipe-it 8.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist snipe/snipe-it: affected < 8.7.0; fixed in 8.7.0 ## Suggested inspection (read-only) - Packagist snipe/snipe-it: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on snipe/snipe-it. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-396x-xmvh-p563 (GitHub-reviewed advisory GHSA-396x-xmvh-p563 lists affected ranges: Packagist snipe/snipe-it >=0 <8.7.0) Commands are suggestions: review each one before running it.
Loading voting…