Vendure affected by external-authentication account takeover: external login linked to a pre-existing account by email without verification
CVE-2026-63472GHSA-6j36-r6pr-59x4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vendure/core 3.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @vendure/core
- Affected
- < 3.7.0
- Fixed in
- 3.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6j36-r6pr-59x4 lists affected ranges: npm @vendure/core >=0 <3.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6j36-r6pr-59x4 lists affected ranges: npm @vendure/core >=0 <3.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-63472: 0.59% estimated exploitation activity in the next 30 days; percentile 48.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
External-authentication account takeover: external login linked to a pre-existing account by email without requiring verification Package: @vendure/core (vendure-ecommerce/vendure, latest master) · [!IMPORTANT] This vulnerability only affects deployments that use external / social authentication (an AuthenticationStrategy other than the built-in native email/password strategy) where that strategy can return an email address the external provider has not verified the user owns. You are affected if all of these are true: - Your store configures one or more external AuthenticationStrategy implementations (custom OAuth / social login / SSO), and - At least one forwards an emailAddress to ExternalAuthenticationService without guaranteeing the provider verified ownership of it (e.g. it doesn't check the provider's emailverified claim, or leaves verified unset/false), and - Customer accounts exist that share an email address with those external identities. You are NOT affected if: - You use…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6j36-r6pr-59x4
- Revision 2 · amended ·
Amended from osv record GHSA-6j36-r6pr-59x4
- Revision 1 · created ·
Published from ghsa record GHSA-6j36-r6pr-59x4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-63472 Advisory: Vendure affected by external-authentication account takeover: external login linked to a pre-existing account by email without verification IDs: CVE-2026-63472, GHSA-6j36-r6pr-59x4 Record: https://patchnext.com/advisories/cve-2026-63472 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @vendure/core 3.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @vendure/core: affected < 3.7.0; fixed in 3.7.0 ## Suggested inspection (read-only) - `npm ls @vendure/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @vendure/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6j36-r6pr-59x4 (GitHub-reviewed advisory GHSA-6j36-r6pr-59x4 lists affected ranges: npm @vendure/core >=0 <3.7.0) - Verified: https://osv.dev/vulnerability/GHSA-6j36-r6pr-59x4 (OSV record GHSA-6j36-r6pr-59x4 lists affected ranges: npm @vendure/core >=0 <3.7.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…