Skip to content

← Actionable
High, CVSS 7.6

Mattermost doesn't sanitize sensitive configuration fields in the Mattermost Calls plugin

CVE-2026-6347GHSA-82j6-4fq7-fx62

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-plugin-calls 1.12.0-rc2; github.com/mattermost/mattermost-server 11.5.2, 11.4.4, 10.11.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:L
EPSS
  • CVE-2026-6347: 0.27% estimated exploitation activity in the next 30 days; percentile 18.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to sanitize sensitive configuration fields in the Mattermost Calls plugin which allows an attacker with access to a support packet to obtain TURN server credentials via the plaintext values present in the exported plugin configuration.. Mattermost Advisory ID: MMSA-2026-00605

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-82j6-4fq7-fx62

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-6347

Advisory: Mattermost doesn't sanitize sensitive configuration fields in the Mattermost Calls plugin
IDs: CVE-2026-6347, GHSA-82j6-4fq7-fx62
Record: https://patchnext.com/advisories/cve-2026-6347 (revision 1, source checked 26 Oct 2026, 15:23 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-plugin-calls 1.12.0-rc2; github.com/mattermost/mattermost-server 11.5.2, 11.4.4, 10.11.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost-plugin-calls: affected < 1.12.0-rc2; fixed in 1.12.0-rc2
- Go github.com/mattermost/mattermost-server: affected >= 11.5.0, < 11.5.2; >= 10.11.0, < 10.11.14; >= 11.4.0, < 11.4.4; fixed in 11.4.4, 10.11.14, 11.5.2

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost-plugin-calls: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost-plugin-calls, github.com/mattermost/mattermost-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-82j6-4fq7-fx62 (GitHub-reviewed advisory GHSA-82j6-4fq7-fx62 lists affected ranges: Go github.com/mattermost/mattermost-server >=11.5.0 =10.11.0 =11.4.0 =0 <1.12.0-rc2)

Commands are suggestions: review each one before running it.

Loading voting…