Skip to content

← Actionable
High, CVSS 7.5

Unleash: Unauthenticated single-request DoS via OpenAPI validation error formatter

CVE-2026-63462GHSA-r5pq-6chh-j3xp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (unleash-server 8.0.2, 7.6.5, 7.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm unleash-server

    Affected
    < 7.5.2>= 7.6.0, < 7.6.5>= 8.0.0, < 8.0.2
    Fixed in
    8.0.2, 7.6.5, 7.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-63462: 0.70% estimated exploitation activity in the next 30 days; percentile 53.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unauthenticated POST to any OpenAPI-validated endpoint, including the anonymous POST /edge/validate and POST /edge/issue-token, crashes the entire Unleash server with one request body of deeply-nested JSON. When request-body validation fails, Unleash builds the error message by calling JSON.stringify on the raw offending value taken from the request body. A value nested a few thousand levels deep makes JSON.stringify recurse past the V8 call-stack limit and throw RangeError: Maximum call stack size exceeded. The throw is synchronous inside an Express error-handling middleware that has no try/catch, and the process registers no uncaughtException handler (only unhandledRejection). Node terminates the process with exit(1). The body parser sets no JSON nesting-depth limit, the payload (about 10 KB at depth 5000) stays far under the 100 KB body-size limit, and the same error formatter serves every API route, so the trigger is route-independent. Result: a remote attacker with no…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r5pq-6chh-j3xp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63462

Advisory: Unleash: Unauthenticated single-request DoS via OpenAPI validation error formatter
IDs: CVE-2026-63462, GHSA-r5pq-6chh-j3xp
Record: https://patchnext.com/advisories/cve-2026-63462 (revision 1, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: unleash-server 8.0.2, 7.6.5, 7.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm unleash-server: affected < 7.5.2; >= 7.6.0, < 7.6.5; >= 8.0.0, < 8.0.2; fixed in 8.0.2, 7.6.5, 7.5.2

## Suggested inspection (read-only)
- `npm ls unleash-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on unleash-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r5pq-6chh-j3xp (GitHub-reviewed advisory GHSA-r5pq-6chh-j3xp lists affected ranges: npm unleash-server >=0 =7.6.0 =8.0.0 <8.0.2)

Commands are suggestions: review each one before running it.

Loading voting…