Skip to content

← Actionable
High, CVSS 7.5amended

Vendure: Unauthenticated ReDoS via regex filter on SQLite backends

CVE-2026-63460GHSA-jgm3-qmp2-c4p7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vendure/core 3.6.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-63460: 0.61% estimated exploitation activity in the next 30 days; percentile 49.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary [!IMPORTANT] Only instances running on the SQLite driver (better-sqlite3) are affected; SQLite is usually used in development/testing backend, so production deployments on PostgreSQL or MySQL/MariaDB are unaffected. The StringOperators.regex filter exposed on the public Shop GraphQL API is evaluated inside the Node.js event loop via a synchronous SQLite user-defined function (UDF). Supplying a catastrophically backtracking pattern blocks the entire event loop, causing a complete denial of service with no authentication required. --- Details Vendure registers a JavaScript UDF so that SQLite can handle the REGEXP operator: packages/core/src/service/helpers/list-query-builder/list-query-builder.ts lines 917–931 The pattern argument is the raw value of StringOperators.regex submitted by the caller. No length limit, timeout, or safe-regex validation is applied before constructing new RegExp(pattern). packages/core/src/service/helpers/list-query-builder/parse-filter-params.ts lines…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jgm3-qmp2-c4p7

  2. Revision 2 · amended ·

    Amended from osv record GHSA-jgm3-qmp2-c4p7

  3. Revision 1 · created ·

    Published from ghsa record GHSA-jgm3-qmp2-c4p7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63460

Advisory: Vendure: Unauthenticated ReDoS via `regex` filter on SQLite backends
IDs: CVE-2026-63460, GHSA-jgm3-qmp2-c4p7
Record: https://patchnext.com/advisories/cve-2026-63460 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @vendure/core 3.6.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @vendure/core: affected <= 3.6.4; fixed in 3.6.5

## Suggested inspection (read-only)
- `npm ls @vendure/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @vendure/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jgm3-qmp2-c4p7 (GitHub-reviewed advisory GHSA-jgm3-qmp2-c4p7 lists affected ranges: npm @vendure/core >=0 <=3.6.4)
- Verified: https://osv.dev/vulnerability/GHSA-jgm3-qmp2-c4p7 (OSV record GHSA-jgm3-qmp2-c4p7 lists affected ranges: npm @vendure/core >=0 <3.6.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…