Vendure has stored XSS in the Admin Dashboard via unsafe HTML-stripping (innerHTML) of entity descriptions
CVE-2026-63459GHSA-xhq9-whgq-49j5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vendure/dashboard 3.6.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.6.5
- Fixed in
- 3.6.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xhq9-whgq-49j5 lists affected ranges: npm @vendure/dashboard >=0 <3.6.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xhq9-whgq-49j5 lists affected ranges: npm @vendure/dashboard >=0 <3.6.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-63459: 0.42% estimated exploitation activity in the next 30 days; percentile 35.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Stored XSS in the Admin Dashboard via unsafe HTML-stripping (innerHTML) of entity descriptions Package: @vendure/dashboard (vendure-ecommerce/vendure, latest master) · Summary The dashboard's RichTextDescriptionCell "strips HTML" from an entity's description by assigning it to a live element's innerHTML and reading back textContent. This pattern still executes active markup: a description containing <img src=x onerror=… runs script when the element is parsed (image resource loads even on a detached node in Chromium/Firefox, firing onerror). Because description is an admin-settable field shown in multiple list views, a lower-privilege administrator can store a payload that executes in a higher-privilege administrator's browser when they open the corresponding list — stored XSS leading to admin-session compromise. Vulnerable code packages/dashboard/src/lib/components/shared/table-cell/order-table-cell-components.tsx innerHTML does not run <script, but it does trigger resource loads /…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xhq9-whgq-49j5
- Revision 2 · amended ·
Amended from osv record GHSA-xhq9-whgq-49j5
- Revision 1 · created ·
Published from ghsa record GHSA-xhq9-whgq-49j5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-63459 Advisory: Vendure has stored XSS in the Admin Dashboard via unsafe HTML-stripping (innerHTML) of entity descriptions IDs: CVE-2026-63459, GHSA-xhq9-whgq-49j5 Record: https://patchnext.com/advisories/cve-2026-63459 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @vendure/dashboard 3.6.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @vendure/dashboard: affected < 3.6.5; fixed in 3.6.5 ## Suggested inspection (read-only) - `npm ls @vendure/dashboard --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @vendure/dashboard. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xhq9-whgq-49j5 (GitHub-reviewed advisory GHSA-xhq9-whgq-49j5 lists affected ranges: npm @vendure/dashboard >=0 <3.6.5) - Verified: https://osv.dev/vulnerability/GHSA-xhq9-whgq-49j5 (OSV record GHSA-xhq9-whgq-49j5 lists affected ranges: npm @vendure/dashboard >=0 <3.6.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…