Skip to content

← Actionable
High, CVSS 7.6amended

Shopify App: Token exchange shop context confusion may allow cross-shop authorization bypass in affected apps

CVE-2026-63414GHSA-6j52-38f8-qhxr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopify_app 23.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems shopify_app

    Affected
    >= 22.1.0, < 23.0.3
    Fixed in
    23.0.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-63414: 0.55% estimated exploitation activity in the next 30 days; percentile 46.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In token-exchange authenticated controllers, `shopify_app` exposes shop context through helpers such as `current_shopify_domain`. Prior to the fix, `current_shopify_domain` could resolve to the sanitized `shop` query parameter instead of the shop identity derived from the verified Shopify ID token or active Shopify session. As a result, a request authenticated for one shop could include a different `shop` query parameter, causing application code to treat the requested shop as the current shop. Applications that used `current_shopify_domain`, or the request `shop` parameter, for authorization decisions, tenant lookup, stored access-token selection, or shop-scoped data access may have been vulnerable to cross-shop context confusion. The patched version hardens token-exchange handling so that: - `current_shopify_domain` resolves to the authenticated shop from the verified token or session. - `authenticated_shopify_domain` exposes the trusted authenticated shop. -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-6j52-38f8-qhxr

  2. Revision 1 · created ·

    Published from ghsa record GHSA-6j52-38f8-qhxr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63414

Advisory: Shopify App: Token exchange shop context confusion may allow cross-shop authorization bypass in affected apps
IDs: CVE-2026-63414, GHSA-6j52-38f8-qhxr
Record: https://patchnext.com/advisories/cve-2026-63414 (revision 2, source checked 30 Oct 2026, 07:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopify_app 23.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems shopify_app: affected >= 22.1.0, < 23.0.3; fixed in 23.0.3

## Suggested inspection (read-only)
- RubyGems shopify_app: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopify_app.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6j52-38f8-qhxr (GitHub-reviewed advisory GHSA-6j52-38f8-qhxr lists affected ranges: RubyGems shopify_app >=22.1.0 <23.0.3)
- Verified: https://osv.dev/vulnerability/GHSA-6j52-38f8-qhxr (OSV record GHSA-6j52-38f8-qhxr lists affected ranges: RubyGems shopify_app >=22.1.0 <23.0.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…