Skip to content

← Actionable
High, CVSS 7.0amended

AnyIO run_process/open_process ignores extra_groups and can retain parent supplementary groups

CVE-2026-63349GHSA-3w57-8xmc-8v26

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (anyio 4.14.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI anyio

    Affected
    >= 4.14.0, < 4.14.2
    Fixed in
    4.14.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.0 · CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-63349: 0.11% estimated exploitation activity in the next 30 days; percentile 1.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

AnyIO 4.14.0 accepts the POSIX extragroups argument on anyio.runprocess() and anyio.openprocess(), but openprocess() forwards the wrong variable to the backend: when extragroups is not None, it assigns kwargs["extragroups"] = group instead of extragroups. As a result, callers cannot reliably clear or set supplementary groups for child processes. In a disposable Linux container, Python's subprocess.run(..., extragroups=[]) clears a synthetic parent supplementary group list, while anyio.runprocess(..., extragroups=[]) preserves the parent groups. If group is also supplied, AnyIO passes an integer as extragroups and the call fails with TypeError. This is a POSIX privilege-dropping correctness issue for applications that rely on AnyIO subprocess helpers to launch less-privileged child processes.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-3w57-8xmc-8v26

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-3w57-8xmc-8v26

  4. Revision 1 · created ·

    Published from ghsa record GHSA-3w57-8xmc-8v26

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63349

Advisory: AnyIO run_process/open_process ignores extra_groups and can retain parent supplementary groups
IDs: CVE-2026-63349, GHSA-3w57-8xmc-8v26
Record: https://patchnext.com/advisories/cve-2026-63349 (revision 4, source checked 26 Oct 2026, 13:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: anyio 4.14.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI anyio: affected >= 4.14.0, < 4.14.2; fixed in 4.14.2

## Suggested inspection (read-only)
- `python -m pip show anyio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on anyio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3w57-8xmc-8v26 (GitHub-reviewed advisory GHSA-3w57-8xmc-8v26 lists affected ranges: PyPI anyio >=4.14.0 <4.14.2)
- Verified: https://osv.dev/vulnerability/GHSA-3w57-8xmc-8v26 (OSV record GHSA-3w57-8xmc-8v26 lists affected ranges: PyPI anyio >=4.14.0 <4.14.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…