Skip to content

← Actionable
Medium, CVSS 5.1amended

RabbitMQ Java client: TrustEverythingTrustManager used by default in useSslProtocol() enables MITM

CVE-2026-63336GHSA-5m9f-rphj-c435

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.rabbitmq:amqp-client 5.33.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N · score source
EPSS
  • CVE-2026-63336: 0.31% estimated exploitation activity in the next 30 days; percentile 23.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Summary com.rabbitmq.client.TrustEverythingTrustManager accepts ANY TLS certificate (including null chains) and is used as the default trust manager when calling ConnectionFactory.useSslProtocol() without arguments. Combined with hostname verification being disabled by default, this enables trivial man-in-the-middle attacks. Affected Components - com.rabbitmq.client.TrustEverythingTrustManager — accepts any certificate - com.rabbitmq.client.ConnectionFactory.useSslProtocol() — uses TrustEverythingTrustManager - Hostname verification disabled by default (enableHostnameVerification() must be called explicitly) - com.rabbitmq.client.ConnectionFactory.getPassword() — returns plaintext with no redaction - Default port 5672 (plaintext) with PLAIN SASL — credentials sent unencrypted POC (Verified on Java 21, amqp-client 5.25.0) Attack Scenarios 1. MITM: Attacker presents self-signed cert → TrustEverythingTrustManager accepts it → all RabbitMQ traffic intercepted 2. Credential…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5m9f-rphj-c435

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5m9f-rphj-c435

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63336

Advisory: RabbitMQ Java client: TrustEverythingTrustManager used by default in useSslProtocol() enables MITM
IDs: CVE-2026-63336, GHSA-5m9f-rphj-c435
Record: https://patchnext.com/advisories/cve-2026-63336 (revision 3, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.rabbitmq:amqp-client 5.33.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.rabbitmq:amqp-client: affected < 5.33.0; fixed in 5.33.0

## Suggested inspection (read-only)
- Maven com.rabbitmq:amqp-client: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.rabbitmq:amqp-client.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5m9f-rphj-c435 (OSV record GHSA-5m9f-rphj-c435 lists affected ranges: Maven com.rabbitmq:amqp-client >=0 <5.33.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5m9f-rphj-c435 (GitHub-reviewed advisory GHSA-5m9f-rphj-c435 lists affected ranges: Maven com.rabbitmq:amqp-client >=0 <5.33.0)

Commands are suggestions: review each one before running it.

Loading voting…