Trivy Plugin Manager has Path Traversal that Allows Arbitrary File Write
CVE-2026-63328GHSA-8rc5-4fr6-64pw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/aquasecurity/trivy 0.72.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/aquasecurity/trivy
- Affected
- < 0.72.0
- Fixed in
- 0.72.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8rc5-4fr6-64pw lists affected ranges: Go github.com/aquasecurity/trivy >=0 <0.72.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6250 lists affected ranges: Go github.com/aquasecurity/trivy >=0 <0.72.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8rc5-4fr6-64pw lists affected ranges: Go github.com/aquasecurity/trivy >=0 <0.72.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-63328: 0.19% estimated exploitation activity in the next 30 days; percentile 8.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Trivy's plugin manager does not fully validate metadata from a plugin's manifest before using it to construct filesystem paths under the plugin root (~/.trivy/plugins). A crafted plugin can cause Trivy to write its files (the manifest and the downloaded plugin binary) outside the plugin root, to an arbitrary location writable by the user running Trivy. Plugins are third-party binaries that Trivy downloads and executes, so Trivy's documentation already advises installing only plugins you trust. This issue does not change that trust boundary: exploitation requires the user to install a malicious plugin in the first place. Affected configurations The vulnerability is triggered only when a user installs an attacker-controlled plugin, for example via trivy plugin install <SOURCE or trivy plugin run <SOURCE. An attacker has to trick a user into installing a plugin they crafted, for instance by publishing it or by getting a malicious source pasted into a command or documentation…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-8rc5-4fr6-64pw
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6250
- Revision 1 · created ·
Published from osv record GHSA-8rc5-4fr6-64pw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-63328 Advisory: Trivy Plugin Manager has Path Traversal that Allows Arbitrary File Write IDs: CVE-2026-63328, GHSA-8rc5-4fr6-64pw Record: https://patchnext.com/advisories/cve-2026-63328 (revision 4, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/aquasecurity/trivy 0.72.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/aquasecurity/trivy: affected < 0.72.0; fixed in 0.72.0 ## Suggested inspection (read-only) - Go github.com/aquasecurity/trivy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/aquasecurity/trivy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8rc5-4fr6-64pw (OSV record GHSA-8rc5-4fr6-64pw lists affected ranges: Go github.com/aquasecurity/trivy >=0 <0.72.0 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6250 (OSV record GO-2026-6250 lists affected ranges: Go github.com/aquasecurity/trivy >=0 <0.72.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8rc5-4fr6-64pw (GitHub-reviewed advisory GHSA-8rc5-4fr6-64pw lists affected ranges: Go github.com/aquasecurity/trivy >=0 <0.72.0) Commands are suggestions: review each one before running it.
Loading voting…