Skip to content

← Actionable
Critical, CVSS 9.8

CodeIgniter: Uploaded file extension validation bypass in is_image and mime_in rules

CVE-2026-63223GHSA-mmj4-63m4-r6h5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (codeigniter4/framework 4.7.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-63223: 0.80% estimated exploitation activity in the next 30 days; percentile 56.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This is an unsafe file upload validation vulnerability that can lead to remote code execution in vulnerable application configurations. Applications are impacted when they: - validate uploads using isimage or mimein without an independent safe extension check, such as extin on patched versions - save uploaded files using the client-supplied filename - place uploads in a web-accessible directory where PHP files can execute Patches Upgrade to v4.7.4 or later. Workarounds - Save uploads outside the public web root, preferably under writable/uploads. - Use $file-store() or $file-move($path, $file-getRandomName()) instead of preserving the original client filename. - Disable script execution in any public upload directory. - Manually verify the client filename extension before moving the file. - For image uploads, reject files when $file-getClientExtension() is not an allowed image extension. - For exact MIME-type validation, reject files when $file-getClientExtension() does not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mmj4-63m4-r6h5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63223

Advisory: CodeIgniter: Uploaded file extension validation bypass in `is_image` and `mime_in` rules
IDs: CVE-2026-63223, GHSA-mmj4-63m4-r6h5
Record: https://patchnext.com/advisories/cve-2026-63223 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: codeigniter4/framework 4.7.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist codeigniter4/framework: affected < 4.7.4; fixed in 4.7.4

## Suggested inspection (read-only)
- Packagist codeigniter4/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on codeigniter4/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mmj4-63m4-r6h5 (GitHub-reviewed advisory GHSA-mmj4-63m4-r6h5 lists affected ranges: Packagist codeigniter4/framework >=0 <4.7.4)

Commands are suggestions: review each one before running it.

Loading voting…