Skip to content

← Actionable
Medium, CVSS 4.8

CodeIgniter: Spoofable forwarded HTTPS headers in IncomingRequest::isSecure()

CVE-2026-63220GHSA-7wmf-pw8j-mc78

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (codeigniter4/framework 4.7.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-63220: 0.17% estimated exploitation activity in the next 30 days; percentile 6.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact IncomingRequest::isSecure() trusted the X-Forwarded-Proto and Front-End-Https headers from any incoming request. In affected deployments, an attacker could spoof these headers and cause the application to incorrectly treat an HTTP request as secure. This may impact applications that rely on isSecure(), forcehttps(), forceGlobalSecureRequests, or similar logic to enforce HTTPS-only access or make security-sensitive decisions. Exploitability depends on deployment configuration. Applications are most exposed if the backend is reachable directly over HTTP, or if a reverse proxy/load balancer forwards client-supplied forwarding headers without stripping or overwriting them. Patches Upgrade to v4.7.4 or later. Workarounds Users who cannot upgrade immediately should enforce HTTP-to-HTTPS redirects outside CodeIgniter, for example with Apache .htaccess/virtual host rules, nginx server blocks, Caddy site config, or load balancer redirect rules. Users should also ensure that reverse…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7wmf-pw8j-mc78

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63220

Advisory: CodeIgniter: Spoofable forwarded HTTPS headers in IncomingRequest::isSecure()
IDs: CVE-2026-63220, GHSA-7wmf-pw8j-mc78
Record: https://patchnext.com/advisories/cve-2026-63220 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: codeigniter4/framework 4.7.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist codeigniter4/framework: affected < 4.7.4; fixed in 4.7.4

## Suggested inspection (read-only)
- Packagist codeigniter4/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on codeigniter4/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7wmf-pw8j-mc78 (GitHub-reviewed advisory GHSA-7wmf-pw8j-mc78 lists affected ranges: Packagist codeigniter4/framework >=0 <4.7.4)

Commands are suggestions: review each one before running it.

Loading voting…