fast-uri vulnerable to host confusion via percent-encoded authority delimiters
CVE-2026-6322GHSA-v39h-62p7-jpjc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 3.1.2, 2.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-uri
- Affected
- >= 3.0.0, <= 3.1.1<= 2.4.0
- Fixed in
- 2.4.1, 3.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v39h-62p7-jpjc lists affected ranges: npm fast-uri >=3.0.0 =0 <2.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v39h-62p7-jpjc lists affected ranges: npm fast-uri >=3.0.0 =0 <=2.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-6322: 0.51% estimated exploitation activity in the next 30 days; percentile 43.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact fast-uri v3.1.1 and earlier decodes percent-encoded authority delimiters (%40 as @, %3A as :) inside the host component and serializes them back as raw characters. This changes the URI structure, turning a hostname into userinfo plus a different host. For example, http://trusted.com%40evil.com/ normalizes to http://trusted.com@evil.com/, which reparses as host evil.com with userinfo trusted.com. Applications that normalize untrusted URLs before host allowlist checks, redirect validation, or outbound request routing can be steered to a different authority than the original URL appeared to contain. Patches Upgrade to fast-uri = 3.1.2, or if you are in the v2.x release line, v2.4.1 Workarounds None. Upgrade to the patched version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v39h-62p7-jpjc
- Revision 1 · created ·
Published from osv record GHSA-v39h-62p7-jpjc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-6322 Advisory: fast-uri vulnerable to host confusion via percent-encoded authority delimiters IDs: CVE-2026-6322, GHSA-v39h-62p7-jpjc Record: https://patchnext.com/advisories/cve-2026-6322 (revision 2, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-uri 3.1.2, 2.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-uri: affected >= 3.0.0, <= 3.1.1; <= 2.4.0; fixed in 2.4.1, 3.1.2 ## Suggested inspection (read-only) - `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-uri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v39h-62p7-jpjc (OSV record GHSA-v39h-62p7-jpjc lists affected ranges: npm fast-uri >=3.0.0 =0 <2.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-v39h-62p7-jpjc (GitHub-reviewed advisory GHSA-v39h-62p7-jpjc lists affected ranges: npm fast-uri >=3.0.0 =0 <=2.4.0) Commands are suggestions: review each one before running it.
Loading voting…