Compress/s2: Integer Overflow or Wraparound and Out-of-bounds Write in compress
CVE-2026-63209GHSA-259r-337f-4rfw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/klauspost/compress 1.18.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/klauspost/compress
- Affected
- <= 1.18.6
- Fixed in
- 1.18.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-259r-337f-4rfw lists affected ranges: Go github.com/klauspost/compress >=0 <1.18.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-5841 lists affected ranges: Go github.com/klauspost/compress >=1.16.0 <1.18.7 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-259r-337f-4rfw lists affected ranges: Go github.com/klauspost/compress >=0 <=1.18.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-63209: 0.57% estimated exploitation activity in the next 30 days; percentile 47.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Signed Integer Overflow in s2.NewDict Summary A signed integer overflow vulnerability in s2.NewDict() allows an attacker to bypass repeat index validation by supplying a dictionary with a uvarint-encoded repeat value exceeding MaxInt64. When Dict.Encode() is subsequently called, the overflowed negative repeat value causes an out-of-bounds memory access via unsafe.Pointer arithmetic, crashing the process with SIGSEGV. Package - Name: github.com/klauspost/compress/s2 - Ecosystem: Go - Affected versions: <= v1.18.6 (all versions with NewDict function) Severity High (7.5) — CVSS v3.1: AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H Vulnerability Type - CWE-190: Integer Overflow or Wraparound - CWE-787: Out-of-bounds Write (via unsafe.Pointer) Description The NewDict() function reads a uvarint from dictionary data and converts it to int: When r exceeds MaxInt64 (9223372036854775807), int(r) overflows to a negative value. Since a negative number is never greater than a positive length, the validation…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-259r-337f-4rfw
- Revision 2 · amended ·
Amended from osv record GO-2026-5841
- Revision 1 · created ·
Published from osv record GHSA-259r-337f-4rfw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-63209 Advisory: Compress/s2: Integer Overflow or Wraparound and Out-of-bounds Write in compress IDs: CVE-2026-63209, GHSA-259r-337f-4rfw Record: https://patchnext.com/advisories/cve-2026-63209 (revision 3, source checked 26 Oct 2026, 15:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/klauspost/compress 1.18.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/klauspost/compress: affected <= 1.18.6; fixed in 1.18.7 ## Suggested inspection (read-only) - Go github.com/klauspost/compress: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/klauspost/compress. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-259r-337f-4rfw (OSV record GHSA-259r-337f-4rfw lists affected ranges: Go github.com/klauspost/compress >=0 <1.18.7 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-5841 (OSV record GO-2026-5841 lists affected ranges: Go github.com/klauspost/compress >=1.16.0 <1.18.7 (fixed)) - Verified: https://github.com/advisories/GHSA-259r-337f-4rfw (GitHub-reviewed advisory GHSA-259r-337f-4rfw lists affected ranges: Go github.com/klauspost/compress >=0 <=1.18.6) Commands are suggestions: review each one before running it.
Loading voting…