Skip to content

← Actionable
High, CVSS 8.2amended

YOURLS has stored XSS in referrer statistics chart via crafted Referer header

CVE-2026-63135GHSA-5h77-88j3-r659

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yourls/yourls 1.10.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N
EPSS
  • CVE-2026-63135: 0.43% estimated exploitation activity in the next 30 days; percentile 36.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary YOURLS stores the HTTP Referer header for short URL redirects and later renders aggregated referrer domains in the per-link statistics page. An unauthenticated attacker can send a crafted Referer header to any existing short URL. When an authenticated administrator or stats-page viewer opens that short URL's statistics page, the crafted referrer is embedded into Google Charts JavaScript without JavaScript-string escaping, causing stored cross-site scripting. This is reachable in default private installations when authenticated users view stats, and in documented configurations where YOURLSPRIVATEINFOS is set to false to make statistics pages public. Details The vulnerable source-to-sink path is: Relevant code: - includes/functions.php:240-243: yourlsgetreferrer() reads $SERVER['HTTPREFERER'], calls yourlssanitizeurlsafe(), and truncates the result to 200 bytes. - includes/functions.php:294-307: yourlsredirectshorturl() calls yourlslogredirect() before redirecting the visitor.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5h77-88j3-r659

  2. Revision 1 · created ·

    Published from osv record GHSA-5h77-88j3-r659

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63135

Advisory: YOURLS has stored XSS in referrer statistics chart via crafted Referer header
IDs: CVE-2026-63135, GHSA-5h77-88j3-r659
Record: https://patchnext.com/advisories/cve-2026-63135 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yourls/yourls 1.10.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist yourls/yourls: affected >= 1.5.1, <= 1.10.3; fixed in 1.10.4

## Suggested inspection (read-only)
- Packagist yourls/yourls: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yourls/yourls.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5h77-88j3-r659 (OSV record GHSA-5h77-88j3-r659 lists affected ranges: Packagist yourls/yourls >=1.5.1 <1.10.4 (fixed))
- Verified: https://github.com/advisories/GHSA-5h77-88j3-r659 (GitHub-reviewed advisory GHSA-5h77-88j3-r659 lists affected ranges: Packagist yourls/yourls >=1.5.1 <=1.10.3)

Commands are suggestions: review each one before running it.

Loading voting…