Wire: Unauthenticated decoder crash via 32-bit length integer overflow in ByteArrayProtoReader32 (incomplete fix of CVE-2026-45799)
CVE-2026-63126GHSA-9rm7-3qhh-h2mc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.squareup.wire:wire-runtime 7.0.0-alpha04, 6.4.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.squareup.wire:wire-runtime
- Affected
- <= 6.4.4>= 7.0.0-alpha01, < 7.0.0-alpha04
- Fixed in
- 7.0.0-alpha04, 6.4.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9rm7-3qhh-h2mc lists affected ranges: Maven com.squareup.wire:wire-runtime >=0 =7.0.0-alpha01 <7.0.0-alpha04 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9rm7-3qhh-h2mc lists affected ranges: Maven com.squareup.wire:wire-runtime >=0 =7.0.0-alpha01 <7.0.0-alpha04
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-63126: 0.82% estimated exploitation activity in the next 30 days; percentile 57.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Wire's protobuf decoders did not consistently validate attacker-controlled length-delimited sizes against the current reader bounds before computing cursor, limit, or pointer positions. In the Kotlin runtime, ProtoAdapter.decode(ByteArray) and ProtoAdapter.decode(ByteString) use the ProtoReader32 fast path implemented by ByteArrayProtoReader32. In ByteArrayProtoReader32.internalNextLengthDelimited(), Wire read an untrusted varint length into an Int and rejected only negative values. A length such as 2147483647 is non-negative, so it passed that check, but pos + length overflowed the signed 32-bit cursor and produced a negative limit. The following if (limit pushedLimit) guard did not catch this because the overflowed value was negative. That invalid limit then reached string, bytes, skip, and scalar-reading paths as an invalid byte count or invalid range. Instead of failing as a checked decode error such as IOException, malformed input could throw unchecked runtime exceptions…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9rm7-3qhh-h2mc
- Revision 1 · created ·
Published from osv record GHSA-9rm7-3qhh-h2mc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-63126 Advisory: Wire: Unauthenticated decoder crash via 32-bit length integer overflow in ByteArrayProtoReader32 (incomplete fix of CVE-2026-45799) IDs: CVE-2026-63126, GHSA-9rm7-3qhh-h2mc Record: https://patchnext.com/advisories/cve-2026-63126 (revision 2, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.squareup.wire:wire-runtime 7.0.0-alpha04, 6.4.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.squareup.wire:wire-runtime: affected <= 6.4.4; >= 7.0.0-alpha01, < 7.0.0-alpha04; fixed in 7.0.0-alpha04, 6.4.5 ## Suggested inspection (read-only) - Maven com.squareup.wire:wire-runtime: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.squareup.wire:wire-runtime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9rm7-3qhh-h2mc (OSV record GHSA-9rm7-3qhh-h2mc lists affected ranges: Maven com.squareup.wire:wire-runtime >=0 =7.0.0-alpha01 <7.0.0-alpha04 (fixed)) - Verified: https://github.com/advisories/GHSA-9rm7-3qhh-h2mc (GitHub-reviewed advisory GHSA-9rm7-3qhh-h2mc lists affected ranges: Maven com.squareup.wire:wire-runtime >=0 =7.0.0-alpha01 <7.0.0-alpha04) Commands are suggestions: review each one before running it.
Loading voting…