MCP Ruby SDK: Unbounded line buffer in stdio transports leads to memory exhaustion (DoS)
CVE-2026-63119GHSA-7683-3w9x-ch42
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp 0.23.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems mcp
- Affected
- <= 0.22.0
- Fixed in
- 0.23.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7683-3w9x-ch42 lists affected ranges: RubyGems mcp >=0 <0.23.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7683-3w9x-ch42 lists affected ranges: RubyGems mcp >=0 <=0.22.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-63119: 0.19% estimated exploitation activity in the next 30 days; percentile 8.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The stdio transports in MCP::Server::Transports::StdioTransport and MCP::Client::Stdio read newline-delimited JSON-RPC frames using IO#gets with no limit argument. CRuby's IO#gets with no limit reads from the current position until the next separator (\n) with no upper bound on the returned string length. A peer that streams bytes without ever emitting a newline causes gets to accumulate the entire stream in a single Ruby String until the process is killed by the operating-system OOM killer. This is the same vulnerability class tracked in sibling MCP SDKs as GHSA-74gp-qhv5-v493 (Kotlin), GHSA-wqgc-pwpr-pq7r (TypeScript), GHSA-655q-2283-6jgj (Python), and others. It was identified during a cross-SDK audit; ruby-sdk had no prior report. Affected code Verified at main @ cf44475c. Server transport — lib/mcp/server/transports/stdiotransport.rb $stdin is the raw process global (only setencoding is applied at line 16); there is no wrapper imposing a length limit. Client transport —…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7683-3w9x-ch42
- Revision 1 · created ·
Published from osv record GHSA-7683-3w9x-ch42
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-63119 Advisory: MCP Ruby SDK: Unbounded line buffer in stdio transports leads to memory exhaustion (DoS) IDs: CVE-2026-63119, GHSA-7683-3w9x-ch42 Record: https://patchnext.com/advisories/cve-2026-63119 (revision 2, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mcp 0.23.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems mcp: affected <= 0.22.0; fixed in 0.23.0 ## Suggested inspection (read-only) - RubyGems mcp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7683-3w9x-ch42 (OSV record GHSA-7683-3w9x-ch42 lists affected ranges: RubyGems mcp >=0 <0.23.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7683-3w9x-ch42 (GitHub-reviewed advisory GHSA-7683-3w9x-ch42 lists affected ranges: RubyGems mcp >=0 <=0.22.0) Commands are suggestions: review each one before running it.
Loading voting…