Skip to content

← Actionable
Medium, CVSS 6.4amended

REDAXO: Missing CSRF Protection on Package Update Action Allows Forced Addon Updates

CVE-2026-63000GHSA-m8r3-22v6-g877

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (redaxo/source 5.21.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:H/A:L
EPSS
  • CVE-2026-63000: 0.15% estimated exploitation activity in the next 30 days; percentile 4.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The rexapiinstallpackageupdate API function (install addon) does not override requiresCsrfProtection(), which defaults to false in the base class rexapifunction. Any authenticated admin can therefore be tricked via a CSRF attack into silently triggering a package update from the REDAXO package server. Details File: redaxo/src/core/lib/apifunction.php:277-280 File: redaxo/src/addons/install/lib/api/apipackageupdate.php:8-39 For comparison, rexapiinstallpackageadd and rexapiinstallpackagedelete both correctly return true. Only rexapiinstallpackageupdate is missing this. PoC When an authenticated admin visits this page, the request is automatically made with their session cookie, causing someaddon to be updated to version fileid=42. Impact An attacker who can lure an admin to a malicious page can force-install specific addon versions. If combined with a supply-chain compromise of a package on redaxo.org, or by targeting a downgrade to a known-vulnerable version, this becomes a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m8r3-22v6-g877

  2. Revision 1 · created ·

    Published from osv record GHSA-m8r3-22v6-g877

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-63000

Advisory: REDAXO: Missing CSRF Protection on Package Update Action Allows Forced Addon Updates
IDs: CVE-2026-63000, GHSA-m8r3-22v6-g877
Record: https://patchnext.com/advisories/cve-2026-63000 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: redaxo/source 5.21.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist redaxo/source: affected <= 5.21.1; fixed in 5.21.2

## Suggested inspection (read-only)
- Packagist redaxo/source: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on redaxo/source.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m8r3-22v6-g877 (OSV record GHSA-m8r3-22v6-g877 lists affected ranges: Packagist redaxo/source >=0 <5.21.2 (fixed))
- Verified: https://github.com/advisories/GHSA-m8r3-22v6-g877 (GitHub-reviewed advisory GHSA-m8r3-22v6-g877 lists affected ranges: Packagist redaxo/source >=0 <=5.21.1)

Commands are suggestions: review each one before running it.

Loading voting…