Skip to content

← Actionable
Medium, CVSS 6.9amended

Smarty Security stream restriction bypass through stream: resource

CVE-2026-62996GHSA-rjhh-76wf-8xmw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (smarty/smarty 5.8.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-62996: 0.51% estimated exploitation activity in the next 30 days; percentile 43.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

smarty/smarty version 5.8.0 can read local files through PHP stream wrappers even when Smarty Security is enabled and all streams are disabled with Security::$streams = null. The bypass uses Smarty's built-in stream: resource type. A template such as: is handled as Smarty resource type stream, so the security check that would normally reject the underlying php wrapper is not applied. StreamPlugin then opens the nested php://filter/... URI directly. For comparison, the direct resource: is blocked with stream 'php' not allowed by security setting. Affected package: - Ecosystem: Packagist / Composer - Package: smarty/smarty - Confirmed affected version: 5.8.0 - Confirmed source reference from Composer lock: 78d259d3b971c59a0cd719c270cc5cbb740c36a7 - Current stable version on Packagist at review time: v5.8.0 - Packagist usage at review time: 41,113,855 total downloads and 840,604 monthly downloads Relevant code paths: - Smarty\Resource\BasePlugin::load(...) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rjhh-76wf-8xmw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rjhh-76wf-8xmw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-62996

Advisory: Smarty Security stream restriction bypass through stream: resource
IDs: CVE-2026-62996, GHSA-rjhh-76wf-8xmw
Record: https://patchnext.com/advisories/cve-2026-62996 (revision 3, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: smarty/smarty 5.8.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist smarty/smarty: affected >= 5.0.0, < 5.8.4; fixed in 5.8.4

## Suggested inspection (read-only)
- Packagist smarty/smarty: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on smarty/smarty.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rjhh-76wf-8xmw (OSV record GHSA-rjhh-76wf-8xmw lists affected ranges: Packagist smarty/smarty >=5.0.0 <5.8.4 (fixed))
- Verified: https://github.com/advisories/GHSA-rjhh-76wf-8xmw (GitHub-reviewed advisory GHSA-rjhh-76wf-8xmw lists affected ranges: Packagist smarty/smarty >=5.0.0 <5.8.4)

Commands are suggestions: review each one before running it.

Loading voting…