Smarty: SSRF via redirect bypass of trusted_uri using {fetch}
CVE-2026-62993GHSA-cq55-c7wv-pxmq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (smarty/smarty 5.8.2, 4.5.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist smarty/smarty
- Affected
- >= 5.0.0, < 5.8.2< 4.5.7
- Fixed in
- 5.8.2, 4.5.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cq55-c7wv-pxmq lists affected ranges: Packagist smarty/smarty >=5.0.0 =0 <4.5.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cq55-c7wv-pxmq lists affected ranges: Packagist smarty/smarty >=5.0.0 =0 <4.5.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2026-62993: 0.57% estimated exploitation activity in the next 30 days; percentile 47.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When a Security policy is active, {fetch} validates the requested remote URL against the trusteduri allowlist via Security::isTrustedUri(). For non-http:// schemes (e.g. https://) the resource was then read with filegetcontents(), which follows HTTP redirects by default. Because isTrustedUri() only validates the initial URL, an open redirect on an otherwise-trusted host could be used to redirect the request to a non-trusted, internal target — bypassing the trusteduri policy. Impact An attacker who can supply a fetch target (or influence one) and who has an open redirect available on a trusted host can cause the server to issue requests to attacker-chosen internal endpoints, defeating the trusteduri allowlist (server-side request forgery). Patches Fixed in 5.8.2. When a security policy is active, {fetch} now passes a stream context that disables redirect following (followlocation = 0, maxredirects = 1) to filegetcontents() for remote resources. Behavior is unchanged when no security…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cq55-c7wv-pxmq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-cq55-c7wv-pxmq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-62993
Advisory: Smarty: SSRF via redirect bypass of trusted_uri using {fetch}
IDs: CVE-2026-62993, GHSA-cq55-c7wv-pxmq
Record: https://patchnext.com/advisories/cve-2026-62993 (revision 3, source checked 26 Oct 2026, 14:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: smarty/smarty 5.8.2, 4.5.7. A vendor fix does not mean a deployment is fixed.
## Affected components
- Packagist smarty/smarty: affected >= 5.0.0, < 5.8.2; < 4.5.7; fixed in 5.8.2, 4.5.7
## Suggested inspection (read-only)
- Packagist smarty/smarty: check the installed version with your package manager.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on smarty/smarty.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cq55-c7wv-pxmq (OSV record GHSA-cq55-c7wv-pxmq lists affected ranges: Packagist smarty/smarty >=5.0.0 =0 <4.5.7 (fixed))
- Verified: https://github.com/advisories/GHSA-cq55-c7wv-pxmq (GitHub-reviewed advisory GHSA-cq55-c7wv-pxmq lists affected ranges: Packagist smarty/smarty >=5.0.0 =0 <4.5.7)
Commands are suggestions: review each one before running it.Loading voting…