Skip to content

← Actionable
Medium, CVSS 5.3amended

YOURLS: Unauthenticated File Inclusion

CVE-2026-62858GHSA-f8ff-652m-j5rx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yourls/yourls 1.10.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-62858: 0.47% estimated exploitation activity in the next 30 days; percentile 40.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary YOURLS versions ≤1.10.4 contain an unauthenticated path traversal vulnerability that allows attackers to include and execute arbitrary PHP files on the server without any credentials. Details The vulnerability exists because YOURLS uses URL sanitization functions (yourlssanitizeurl(), yourlsescurl()) to filter request paths, but these functions are designed to clean URLs, not filesystem paths. They preserve / and . characters, allowing ../ sequences to pass through unfiltered. The unsanitized keyword is then directly concatenated into a filesystem path and passed to fileexists() and later include() operations, enabling path traversal attacks. Data Flow: Proof of Concept (POC) In the concept validation, we assume that the attacker has uploaded a test.php file to the web root directory, but it cannot be accessed directly. (Of course, it could also be any path, such as /tmp/test.php) Setup Place a test file in web root: ./test.php: <img width="502" height="126" alt="image"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f8ff-652m-j5rx

  2. Revision 1 · created ·

    Published from osv record GHSA-f8ff-652m-j5rx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-62858

Advisory: YOURLS: Unauthenticated File Inclusion
IDs: CVE-2026-62858, GHSA-f8ff-652m-j5rx
Record: https://patchnext.com/advisories/cve-2026-62858 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yourls/yourls 1.10.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist yourls/yourls: affected <= 1.10.4; fixed in 1.10.5

## Suggested inspection (read-only)
- Packagist yourls/yourls: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yourls/yourls.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f8ff-652m-j5rx (OSV record GHSA-f8ff-652m-j5rx lists affected ranges: Packagist yourls/yourls >=0 <1.10.5 (fixed))
- Verified: https://github.com/advisories/GHSA-f8ff-652m-j5rx (GitHub-reviewed advisory GHSA-f8ff-652m-j5rx lists affected ranges: Packagist yourls/yourls >=0 <=1.10.4)

Commands are suggestions: review each one before running it.

Loading voting…