Omnigent: Shared Agent Bundle Overwrite Leads to Authenticated Runner RCE
CVE-2026-62674GHSA-jrrm-9hc7-2v3h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (omnigent 0.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI omnigent
- Affected
- < 0.3.0
- Fixed in
- 0.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jrrm-9hc7-2v3h lists affected ranges: PyPI omnigent >=0 <0.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jrrm-9hc7-2v3h lists affected ranges: PyPI omnigent >=0 <0.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-62674: 0.51% estimated exploitation activity in the next 30 days; percentile 43.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authenticated user with edit access to their own session can overwrite a shared/template agent by uploading a full agent bundle through PUT /sessions/{sessionid}/agent. Shared/template agents are shown as not MCP-editable, but this upload path still accepts a replacement bundle. By adding a stdio MCP server to the shared agent, the attacker can cause future runner sessions using that shared agent to start an attacker-controlled command. Details The vulnerable endpoint is the full agent bundle upload route: PUT /sessions/{sessionid}/agent This route checks whether the caller can edit the session: LEVELEDIT session permission check But it does not check whether the bound agent is a shared/template agent. Shared/template agents have: The API already exposes that these agents are not meant to be MCP-editable: mcpserverseditable is false for shared/template agents The direct MCP edit endpoint correctly blocks shared/template agents: sessionmcpservers.py shared-agent guard The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jrrm-9hc7-2v3h
- Revision 2 · amended ·
Amended from osv record GHSA-jrrm-9hc7-2v3h
- Revision 1 · created ·
Published from ghsa record GHSA-jrrm-9hc7-2v3h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-62674 Advisory: Omnigent: Shared Agent Bundle Overwrite Leads to Authenticated Runner RCE IDs: CVE-2026-62674, GHSA-jrrm-9hc7-2v3h Record: https://patchnext.com/advisories/cve-2026-62674 (revision 3, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: omnigent 0.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI omnigent: affected < 0.3.0; fixed in 0.3.0 ## Suggested inspection (read-only) - `python -m pip show omnigent`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on omnigent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jrrm-9hc7-2v3h (GitHub-reviewed advisory GHSA-jrrm-9hc7-2v3h lists affected ranges: PyPI omnigent >=0 <0.3.0) - Verified: https://osv.dev/vulnerability/GHSA-jrrm-9hc7-2v3h (OSV record GHSA-jrrm-9hc7-2v3h lists affected ranges: PyPI omnigent >=0 <0.3.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…