KubeEdge: Command Injection in NodeUpgradeJob - RCE on edge nodes via v1alpha2 API
CVE-2026-62371GHSA-5jpj-293f-rhvj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubeedge/kubeedge 1.23.1, 1.22.2, 1.21.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kubeedge/kubeedge
- Affected
- >= 1.12.0, < 1.21.2>= 1.22.0, < 1.22.2>= 1.23.0, < 1.23.1
- Fixed in
- 1.21.2, 1.23.1, 1.22.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5jpj-293f-rhvj lists affected ranges: Go github.com/kubeedge/kubeedge >=1.12.0 =1.22.0 =1.23.0 <1.23.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6557 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.12.0 =1.22.0 =1.23.0 <1.23.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5jpj-293f-rhvj lists affected ranges: Go github.com/kubeedge/kubeedge >=1.12.0 =1.22.0 =1.23.0 <1.23.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-62371: 0.48% estimated exploitation activity in the next 30 days; percentile 41.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The KubeEdge NodeUpgradeJob handler constructed the keadm upgrade edge command by concatenating the user-controlled spec.version and spec.image fields into a shell command. An authenticated user with permission to create or update NodeUpgradeJob resources through the v1alpha2 API could include shell metacharacters in either field. When the upgrade job was processed, the injected command could be executed on the targeted edge node with the privileges available to the upgrade process. Successful exploitation could result in arbitrary command execution and compromise the confidentiality, integrity, and availability of the affected edge node. Patches The fix removes shell-based command construction and invokes keadm using a structured argument list through exec.Command. The version and image values are passed as separate literal arguments and are no longer interpreted by a command shell. The fixed versions: KubeEdge v1.23.1 KubeEdge v1.22.2 KubeEdge v1.21.2 Workarounds Until a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5jpj-293f-rhvj
- Revision 2 · amended ·
Amended from osv record GO-2026-6557
- Revision 1 · created ·
Published from osv record GHSA-5jpj-293f-rhvj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-62371 Advisory: KubeEdge: Command Injection in NodeUpgradeJob - RCE on edge nodes via v1alpha2 API IDs: CVE-2026-62371, GHSA-5jpj-293f-rhvj Record: https://patchnext.com/advisories/cve-2026-62371 (revision 3, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kubeedge/kubeedge 1.23.1, 1.22.2, 1.21.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kubeedge/kubeedge: affected >= 1.12.0, < 1.21.2; >= 1.22.0, < 1.22.2; >= 1.23.0, < 1.23.1; fixed in 1.21.2, 1.23.1, 1.22.2 ## Suggested inspection (read-only) - Go github.com/kubeedge/kubeedge: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kubeedge/kubeedge. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5jpj-293f-rhvj (OSV record GHSA-5jpj-293f-rhvj lists affected ranges: Go github.com/kubeedge/kubeedge >=1.12.0 =1.22.0 =1.23.0 <1.23.1 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6557 (OSV record GO-2026-6557 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.12.0 =1.22.0 =1.23.0 <1.23.1 (fixed)) - Verified: https://github.com/advisories/GHSA-5jpj-293f-rhvj (GitHub-reviewed advisory GHSA-5jpj-293f-rhvj lists affected ranges: Go github.com/kubeedge/kubeedge >=1.12.0 =1.22.0 =1.23.0 <1.23.1) Commands are suggestions: review each one before running it.
Loading voting…