KubeEdge: Unbounded allocation in viaduct packer enables authenticated remote DoS against CloudHub
CVE-2026-62370GHSA-gfw4-49f9-cp25
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubeedge/kubeedge 1.23.1, 1.22.2, 1.21.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kubeedge/kubeedge
- Affected
- >= 1.0.0, < 1.21.2>= 1.22.0, < 1.22.2>= 1.23.0, < 1.23.1
- Fixed in
- 1.21.2, 1.23.1, 1.22.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gfw4-49f9-cp25 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.0.0 =1.22.0 =1.23.0 <1.23.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6569 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.0.0 =1.22.0 =1.23.0 <1.23.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gfw4-49f9-cp25 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.0.0 =1.22.0 =1.23.0 <1.23.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-62370: 0.50% estimated exploitation activity in the next 30 days; percentile 43.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary KubeEdge CloudHub uses the viaduct packer to decode messages received from connected peers. The packer reads a 32-bit payload length from the message header and previously allocated a buffer of that size without enforcing an upper bound. An authenticated peer that can establish a viaduct connection to CloudHub can send a crafted message header containing an excessively large payload length. This may cause CloudHub to allocate a large amount of memory and can result in memory exhaustion, process termination, or denial of service. Impact A successfully authenticated malicious or compromised edge node may repeatedly send crafted viaduct message headers to increase CloudHub memory consumption. Depending on available memory and deployment limits, exploitation may cause: Increased CloudHub memory usage Out-of-memory termination CloudHub restart loops Temporary disruption of cloud-edge communication Authentication to the viaduct endpoint is required. This issue does not provide…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-gfw4-49f9-cp25
- Revision 2 · amended ·
Amended from osv record GO-2026-6569
- Revision 1 · created ·
Published from osv record GHSA-gfw4-49f9-cp25
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-62370 Advisory: KubeEdge: Unbounded allocation in viaduct packer enables authenticated remote DoS against CloudHub IDs: CVE-2026-62370, GHSA-gfw4-49f9-cp25 Record: https://patchnext.com/advisories/cve-2026-62370 (revision 3, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kubeedge/kubeedge 1.23.1, 1.22.2, 1.21.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kubeedge/kubeedge: affected >= 1.0.0, < 1.21.2; >= 1.22.0, < 1.22.2; >= 1.23.0, < 1.23.1; fixed in 1.21.2, 1.23.1, 1.22.2 ## Suggested inspection (read-only) - Go github.com/kubeedge/kubeedge: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kubeedge/kubeedge. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gfw4-49f9-cp25 (OSV record GHSA-gfw4-49f9-cp25 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.0.0 =1.22.0 =1.23.0 <1.23.1 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6569 (OSV record GO-2026-6569 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.0.0 =1.22.0 =1.23.0 <1.23.1 (fixed)) - Verified: https://github.com/advisories/GHSA-gfw4-49f9-cp25 (GitHub-reviewed advisory GHSA-gfw4-49f9-cp25 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.0.0 =1.22.0 =1.23.0 <1.23.1) Commands are suggestions: review each one before running it.
Loading voting…