KubeEdge: keadm DecompressTarGz path traversal enables arbitrary file write on Windows during edge node join
CVE-2026-62369GHSA-9vm9-pqxx-x83v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubeedge/kubeedge 1.23.1, 1.22.2, 1.21.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kubeedge/kubeedge
- Affected
- >= 1.16.0, < 1.21.2>= 1.22.0, < 1.22.2>= 1.23.0, < 1.23.1
- Fixed in
- 1.21.2, 1.23.1, 1.22.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9vm9-pqxx-x83v lists affected ranges: Go github.com/kubeedge/kubeedge >=1.16.0 =1.22.0 =1.23.0 <1.23.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6563 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.16.0 =1.22.0 =1.23.0 <1.23.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9vm9-pqxx-x83v lists affected ranges: Go github.com/kubeedge/kubeedge >=1.16.0 =1.22.0 =1.23.0 <1.23.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
- EPSS
- CVE-2026-62369: 0.63% estimated exploitation activity in the next 30 days; percentile 50.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description KubeEdge keadm contains a path traversal vulnerability in the DecompressTarGz archive extraction function. Archive entry names were joined directly with the extraction destination without sufficient validation. A crafted tar.gz archive containing parent-directory components, Windows-style backslashes, absolute paths, or drive-prefixed paths could cause files to be written outside the intended extraction directory. The issue is particularly relevant to Windows edge nodes during the keadm join or installation process when keadm extracts downloaded component archives. Impact An attacker who can cause an affected keadm process to extract a malicious archive may write or overwrite files outside the intended destination directory with the privileges of the user running keadm. On Windows edge nodes, this may allow modification of configuration files, executable files, service-related files, or other writable system locations. Depending on the overwritten file and the privileges…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9vm9-pqxx-x83v
- Revision 2 · amended ·
Amended from osv record GO-2026-6563
- Revision 1 · created ·
Published from osv record GHSA-9vm9-pqxx-x83v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-62369 Advisory: KubeEdge: keadm DecompressTarGz path traversal enables arbitrary file write on Windows during edge node join IDs: CVE-2026-62369, GHSA-9vm9-pqxx-x83v Record: https://patchnext.com/advisories/cve-2026-62369 (revision 3, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kubeedge/kubeedge 1.23.1, 1.22.2, 1.21.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kubeedge/kubeedge: affected >= 1.16.0, < 1.21.2; >= 1.22.0, < 1.22.2; >= 1.23.0, < 1.23.1; fixed in 1.21.2, 1.23.1, 1.22.2 ## Suggested inspection (read-only) - Go github.com/kubeedge/kubeedge: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kubeedge/kubeedge. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9vm9-pqxx-x83v (OSV record GHSA-9vm9-pqxx-x83v lists affected ranges: Go github.com/kubeedge/kubeedge >=1.16.0 =1.22.0 =1.23.0 <1.23.1 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6563 (OSV record GO-2026-6563 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.16.0 =1.22.0 =1.23.0 <1.23.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9vm9-pqxx-x83v (GitHub-reviewed advisory GHSA-9vm9-pqxx-x83v lists affected ranges: Go github.com/kubeedge/kubeedge >=1.16.0 =1.22.0 =1.23.0 <1.23.1) Commands are suggestions: review each one before running it.
Loading voting…