Skip to content

← Actionable
Low, CVSS 2.3amended

wlc may disclose API tokens to project-configured URLs

CVE-2026-62364GHSA-3mqq-hv9c-85hc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wlc 2.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wlc

    Affected
    < 2.0.1
    Fixed in
    2.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.3 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-62364: 0.08% estimated exploitation activity in the next 30 days; percentile 0.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact wlc could send an unscoped API token to an unintended server when run inside a directory tree containing attacker-controlled project configuration. If .weblate, .weblate.ini, or weblate.ini defines an API url, and the user supplies a token with WLCKEY or --key without also pinning the URL, wlc would send the token to the project-configured URL. Impacted users are those running wlc in untrusted repositories, pull request checkouts, or directories with untrusted ancestor configuration while using WLCKEY or --key. Patches The issue is patched in wlc 2.0.1 via https://github.com/WeblateOrg/wlc/pull/1500. The fix rejects unscoped keys when the API URL comes from automatically discovered project configuration: - WLCKEY now requires WLCURL. - --key now requires --url. - URL-scoped keys in the [keys] configuration section remain supported. Users should upgrade to wlc 2.0.1 or newer. Workarounds Without upgrading, users can avoid the issue by explicitly pinning the API URL whenever…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3mqq-hv9c-85hc

  2. Revision 2 · amended ·

    Amended from osv record GHSA-3mqq-hv9c-85hc

  3. Revision 1 · created ·

    Published from ghsa record GHSA-3mqq-hv9c-85hc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-62364

Advisory: wlc may disclose API tokens to project-configured URLs
IDs: CVE-2026-62364, GHSA-3mqq-hv9c-85hc
Record: https://patchnext.com/advisories/cve-2026-62364 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wlc 2.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wlc: affected < 2.0.1; fixed in 2.0.1

## Suggested inspection (read-only)
- `python -m pip show wlc`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wlc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3mqq-hv9c-85hc (GitHub-reviewed advisory GHSA-3mqq-hv9c-85hc lists affected ranges: PyPI wlc >=0 <2.0.1)
- Verified: https://osv.dev/vulnerability/GHSA-3mqq-hv9c-85hc (OSV record GHSA-3mqq-hv9c-85hc lists affected ranges: PyPI wlc >=0 <2.0.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…