Cloudreve WOPI view sessions can write files and WOPI access token secret is ignored
CVE-2026-62323GHSA-c3jm-gv5r-9wcp
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/cloudreve/Cloudreve/v3
- Affected
- <= 3.0.0-20250225100611-da4e44b77af4
- Fixed in
- no fixed version recorded
Go github.com/cloudreve/Cloudreve
- Affected
- every version
- Fixed in
- no fixed version recorded
Go github.com/cloudreve/Cloudreve/v4
- Affected
- < 4.0.0-20260626022433-f3347130ac48
- Fixed in
- 4.0.0-20260626022433-f3347130ac48
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6104 lists affected ranges: Go github.com/cloudreve/Cloudreve >=0; Go github.com/cloudreve/Cloudreve/v3 >=0; Go github.com/cloudreve/Cloudreve/v4 >=0 <4.0.0-20260626022433-f3347130ac48 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c3jm-gv5r-9wcp lists affected ranges: Go github.com/cloudreve/Cloudreve/v4 >=0 =0 <=3.0.0-20250225100611-da4e44b77af4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N
- EPSS
- CVE-2026-62323: 0.31% estimated exploitation activity in the next 30 days; percentile 23.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Cloudreve WOPI access tokens are generated as <session-id.<random-secret, but the WOPI middleware validates only the session id prefix and never compares the supplied token to the stored token. In addition, a WOPI viewer session does not store or enforce the requested viewer action. A session created for a view or preview action can still call WOPI write routes if the underlying file is writable by the session user. Impact A WOPI integration that is only expected to view a user's file can modify that file through the WOPI write endpoints. If the WOPI URL or session id leaks, the random token suffix does not protect the session because any suffix is accepted for an existing session id. This affects deployments that configure WOPI viewers for user files. The attacker primitive is strongest when a malicious or compromised WOPI viewer receives a view-only URL and then writes content back to Cloudreve. Affected version Verified in source and runtime on latest master commit…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c3jm-gv5r-9wcp
- Revision 1 · created ·
Published from osv record GO-2026-6104
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-62323 Advisory: Cloudreve WOPI view sessions can write files and WOPI access token secret is ignored IDs: CVE-2026-62323, GHSA-c3jm-gv5r-9wcp Record: https://patchnext.com/advisories/cve-2026-62323 (revision 2, source checked 26 Oct 2026, 15:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/cloudreve/Cloudreve/v4 4.0.0-20260626022433-f3347130ac48. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cloudreve/Cloudreve/v3: affected <= 3.0.0-20250225100611-da4e44b77af4 - Go github.com/cloudreve/Cloudreve: affected every version - Go github.com/cloudreve/Cloudreve/v4: affected < 4.0.0-20260626022433-f3347130ac48; fixed in 4.0.0-20260626022433-f3347130ac48 ## Suggested inspection (read-only) - Go github.com/cloudreve/Cloudreve/v3: check the installed version with your package manager. - Go github.com/cloudreve/Cloudreve: check the installed version with your package manager. - Go github.com/cloudreve/Cloudreve/v4: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cloudreve/Cloudreve/v3, github.com/cloudreve/Cloudreve, github.com/cloudreve/Cloudreve/v4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6104 (OSV record GO-2026-6104 lists affected ranges: Go github.com/cloudreve/Cloudreve >=0; Go github.com/cloudreve/Cloudreve/v3 >=0; Go github.com/cloudreve/Cloudreve/v4 >=0 <4.0.0-20260626022433-f3347130ac48 (fixed)) - Verified: https://github.com/advisories/GHSA-c3jm-gv5r-9wcp (GitHub-reviewed advisory GHSA-c3jm-gv5r-9wcp lists affected ranges: Go github.com/cloudreve/Cloudreve/v4 >=0 =0 <=3.0.0-20250225100611-da4e44b77af4) Commands are suggestions: review each one before running it.
Loading voting…