Skip to content

← Actionable
Medium, CVSS 6.5amended

Python Social Auth: Login CSRF in LINE backend (LineOAuth2) — missing OAuth state validation (incomplete fix of 5.0.0 campaign)

CVE-2026-62322GHSA-526j-582w-7fm9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (social-auth-core 5.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-62322: 0.15% estimated exploitation activity in the next 30 days; percentile 4.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Applications using the LINE Login backend are vulnerable to login CSRF / forced authentication. An attacker can start a LINE authorization flow for an account they control and trick a victim into visiting the callback URL with the attacker’s authorization code. Because the LINE backend did not validate the returned OAuth state, the application could accept the forged callback and log the victim in as the attacker-controlled LINE account. If account linking is enabled, the same flaw can allow an attacker to link their LINE identity to a victim’s existing authenticated account, creating a persistent unauthorized login path. Patches https://github.com/python-social-auth/social-core/pull/1829 Workarounds Only applications that enable the LINE backend are affected. Credits Thanks to Ta Duc Thien and Duc Anh Nguyen for reproting this via GitHub.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-526j-582w-7fm9

  2. Revision 2 · amended ·

    Amended from osv record GHSA-526j-582w-7fm9

  3. Revision 1 · created ·

    Published from ghsa record GHSA-526j-582w-7fm9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-62322

Advisory: Python Social Auth: Login CSRF in LINE backend (LineOAuth2) — missing OAuth state validation (incomplete fix of 5.0.0 campaign)
IDs: CVE-2026-62322, GHSA-526j-582w-7fm9
Record: https://patchnext.com/advisories/cve-2026-62322 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: social-auth-core 5.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI social-auth-core: affected < 5.0.2; fixed in 5.0.2

## Suggested inspection (read-only)
- `python -m pip show social-auth-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on social-auth-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-526j-582w-7fm9 (GitHub-reviewed advisory GHSA-526j-582w-7fm9 lists affected ranges: PyPI social-auth-core >=0 <5.0.2)
- Verified: https://osv.dev/vulnerability/GHSA-526j-582w-7fm9 (OSV record GHSA-526j-582w-7fm9 lists affected ranges: PyPI social-auth-core >=0 <5.0.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…