Skip to content

← Actionable
Medium, CVSS 6.5amended

OpenCVE: Server-Side Request Forgery (SSRF) in notifications

CVE-2026-62282GHSA-ch3g-4xvr-674q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (opencve 3.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI opencve

    Affected
    <= 1.5.0
    Fixed in
    3.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-62282: 0.45% estimated exploitation activity in the next 30 days; percentile 39.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact OpenCVE contains a Server-Side Request Forgery (SSRF) vulnerability in the notification testing functionality for both Webhook and Slack integrations. An authenticated user with permission to configure notification channels can trigger test requests to arbitrary HTTP(S) endpoints. Insufficient validation of target destinations allows requests to be sent to hosts reachable from the OpenCVE server, including internal network resources, localhost interfaces, and cloud metadata services. Successful exploitation could allow an attacker to interact with internal services that are not otherwise accessible from the Internet and retrieve information from HTTP-based services reachable by the OpenCVE instance. Patches The vulnerability has been fixed in OpenCVE version 3.0.0, users should upgrade to version 3.0.0 or later. The fix introduces additional validation of user-supplied URLs used by the notification testing functionality and prevents requests to localhost, private network…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-ch3g-4xvr-674q

  2. Revision 2 · amended ·

    Amended from osv record GHSA-ch3g-4xvr-674q

  3. Revision 1 · created ·

    Published from ghsa record GHSA-ch3g-4xvr-674q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-62282

Advisory: OpenCVE: Server-Side Request Forgery (SSRF) in notifications
IDs: CVE-2026-62282, GHSA-ch3g-4xvr-674q
Record: https://patchnext.com/advisories/cve-2026-62282 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: opencve 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI opencve: affected <= 1.5.0; fixed in 3.0.0

## Suggested inspection (read-only)
- `python -m pip show opencve`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on opencve.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ch3g-4xvr-674q (GitHub-reviewed advisory GHSA-ch3g-4xvr-674q lists affected ranges: PyPI opencve >=0 <=1.5.0)
- Verified: https://osv.dev/vulnerability/GHSA-ch3g-4xvr-674q (OSV record GHSA-ch3g-4xvr-674q lists affected ranges: PyPI opencve >=0 <3.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…