Skip to content

← Actionable
Medium, CVSS 6.1

OpenAM Reflected XSS in the OAuth2/OIDC wap consent page

CVE-2026-62280GHSA-vqxv-6xrh-49cp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openidentityplatform.openam:openam-oauth2 16.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-62280: 0.33% estimated exploitation activity in the next 30 days; percentile 25.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The OAuth2/OIDC consent page rendered for display=wap authorize requests reflected several request-derived values into the HTML response without escaping. An attacker who induces a user with an active OpenAM session to follow a crafted authorize link can execute arbitrary JavaScript in the OpenAM origin. This is the same vulnerability class as CVE-2026-44203; that fix did not cover this code path. Impact Arbitrary JavaScript execution in the OpenAM origin in the victim's authenticated context — enabling session/cookie theft, CSRF-token exfiltration, and actions on behalf of the victim, up to administrative takeover if the victim is an administrator. Reachable on any deployment with at least one registered OAuth2 client; no attacker-controlled client and no special configuration required. Mitigation - Upgrade to 16.1.2 (or later). - Until then, restrict/limit access to the OAuth2 authorize endpoint and treat unsolicited display=wap authorize links as untrusted.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vqxv-6xrh-49cp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-62280

Advisory: OpenAM Reflected XSS in the OAuth2/OIDC `wap` consent page
IDs: CVE-2026-62280, GHSA-vqxv-6xrh-49cp
Record: https://patchnext.com/advisories/cve-2026-62280 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.openidentityplatform.openam:openam-oauth2 16.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.openidentityplatform.openam:openam-oauth2: affected >= 13.0.0, <= 16.1.1; fixed in 16.1.2

## Suggested inspection (read-only)
- Maven org.openidentityplatform.openam:openam-oauth2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.openidentityplatform.openam:openam-oauth2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vqxv-6xrh-49cp (GitHub-reviewed advisory GHSA-vqxv-6xrh-49cp lists affected ranges: Maven org.openidentityplatform.openam:openam-oauth2 >=13.0.0 <=16.1.1)

Commands are suggestions: review each one before running it.

Loading voting…