@sylphx/pdf-reader-mcp: HTTP transport accepts unauthenticated requests despite a configured MCP_API_KEY
CVE-2026-62264GHSA-q344-5v34-gm84
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sylphx/pdf-reader-mcp 3.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.2.0, < 3.0.1
- Fixed in
- 3.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q344-5v34-gm84 lists affected ranges: npm @sylphx/pdf-reader-mcp >=2.2.0 <3.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q344-5v34-gm84 lists affected ranges: npm @sylphx/pdf-reader-mcp >=2.2.0 <3.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-62264: 0.45% estimated exploitation activity in the next 30 days; percentile 39.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When `@sylphx/pdf-reader-mcp` is run as an HTTP server (`MCP_TRANSPORT=http`), it reads the `MCP_API_KEY` environment variable and logs `API key authentication enabled (X-API-Key header)` at startup, but it never validated the `X-API-Key` header on incoming requests. The key was read into a variable and never enforced on the request path. As a result, the `/mcp` endpoint accepted unauthenticated requests. Combined with the default bind address of `0.0.0.0` (all interfaces), any client able to reach the port could invoke every PDF tool and read the contents of any PDF the server process could open anywhere on the host. URL-based sources also enable limited SSRF (private/loopback addresses are blocked by default unless `--allow-private-ips` is set). The misleading startup log made the exposure silent: an operator who set `MCP_API_KEY` reasonably believed the server was protected when it was not. This affects only the opt-in HTTP transport; the default `stdio` transport…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-q344-5v34-gm84
- Revision 1 · created ·
Published from ghsa record GHSA-q344-5v34-gm84
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-62264 Advisory: @sylphx/pdf-reader-mcp: HTTP transport accepts unauthenticated requests despite a configured MCP_API_KEY IDs: CVE-2026-62264, GHSA-q344-5v34-gm84 Record: https://patchnext.com/advisories/cve-2026-62264 (revision 2, source checked 30 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @sylphx/pdf-reader-mcp 3.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @sylphx/pdf-reader-mcp: affected >= 2.2.0, < 3.0.1; fixed in 3.0.1 ## Suggested inspection (read-only) - `npm ls @sylphx/pdf-reader-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @sylphx/pdf-reader-mcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q344-5v34-gm84 (GitHub-reviewed advisory GHSA-q344-5v34-gm84 lists affected ranges: npm @sylphx/pdf-reader-mcp >=2.2.0 <3.0.1) - Verified: https://osv.dev/vulnerability/GHSA-q344-5v34-gm84 (OSV record GHSA-q344-5v34-gm84 lists affected ranges: npm @sylphx/pdf-reader-mcp >=2.2.0 <3.0.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…