Grav: .htaccess file extension rules bypass via case variation on case-insensitive filesystems
CVE-2026-62230GHSA-vwg3-w8w3-pc79
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 2.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- < 2.0.4
- Fixed in
- 2.0.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vwg3-w8w3-pc79 lists affected ranges: Packagist getgrav/grav >=0 <2.0.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vwg3-w8w3-pc79 lists affected ranges: Packagist getgrav/grav >=0 <2.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-62230: 0.38% estimated exploitation activity in the next 30 days; percentile 32.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
- CVE-2026-62673: 0.54% estimated exploitation activity in the next 30 days; percentile 45.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The default .htaccess shipped with Grav (and the reference webserver-configs/htaccess.txt) contains security rules that block direct HTTP access to sensitive file types (.yaml, .yml, .php, .json, .twig, etc.) under user/ and system/vendor/ directories. However, these rules lack the [NC] (No Case) flag, making them case-sensitive. On case-insensitive filesystems (Windows/NTFS, macOS/HFS+, or Linux with Docker volumes mounted from Windows/macOS), an attacker can bypass these rules by requesting files with uppercase extensions (e.g., .YAML, .PHP, .JSON). Affected Versions - Grav 2.0.1 (latest stable as of June 2026) — confirmed - Grav 1.7.x — likely affected (same .htaccess rules) - All versions shipping the current webserver-configs/htaccess.txt Affected Component File: .htaccess (root of Grav installation) Reference: webserver-configs/htaccess.txt Affected Rules (lines 68, 70, 72) All three rules use [F] without [NC], making the extension match case-sensitive. Steps to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vwg3-w8w3-pc79
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vwg3-w8w3-pc79
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-62230 Advisory: Grav: .htaccess file extension rules bypass via case variation on case-insensitive filesystems IDs: CVE-2026-62230, GHSA-vwg3-w8w3-pc79 Record: https://patchnext.com/advisories/cve-2026-62230 (revision 3, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 2.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected < 2.0.4; fixed in 2.0.4 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vwg3-w8w3-pc79 (OSV record GHSA-vwg3-w8w3-pc79 lists affected ranges: Packagist getgrav/grav >=0 <2.0.4 (fixed)) - Verified: https://github.com/advisories/GHSA-vwg3-w8w3-pc79 (GitHub-reviewed advisory GHSA-vwg3-w8w3-pc79 lists affected ranges: Packagist getgrav/grav >=0 <2.0.4) Commands are suggestions: review each one before running it.
Loading voting…