KubeEdge: ConfigUpdateJob updateFields enables remote shell injection and code execution on edge nodes
CVE-2026-62182GHSA-m3c6-2p7h-cfr3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubeedge/kubeedge 1.23.1, 1.22.2, 1.21.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kubeedge/kubeedge
- Affected
- >= 1.21.0, < 1.21.2>= 1.22.0, < 1.22.2>= 1.23.0, < 1.23.1
- Fixed in
- 1.21.2, 1.23.1, 1.22.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6573 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.21.0 =1.22.0 =1.23.0 <1.23.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m3c6-2p7h-cfr3 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.21.0 =1.22.0 =1.23.0 <1.23.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m3c6-2p7h-cfr3 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.21.0 =1.22.0 =1.23.0 <1.23.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-62182: 0.48% estimated exploitation activity in the next 30 days; percentile 41.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description KubeEdge ConfigUpdateJob processing was vulnerable to command injection on edge nodes. The updateFields values from a ConfigUpdateJob were concatenated into a command string and executed through a system shell. An authenticated user with sufficient permissions to create or update ConfigUpdateJob resources could include shell metacharacters in the supplied configuration fields and cause unintended commands to be executed on targeted edge nodes. Impact Successful exploitation could allow an authenticated attacker to execute arbitrary commands on affected edge nodes with the privileges of the KubeEdge process handling the ConfigUpdateJob. The attacker must already have permission to create or modify ConfigUpdateJob resources and target an enrolled edge node. Patches The fix removes shell-based command construction and invokes keadm config-update using structured command arguments. The complete --set value is passed as a single literal argument, preventing shell…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m3c6-2p7h-cfr3
- Revision 2 · amended ·
Amended from osv record GO-2026-6573
- Revision 1 · created ·
Published from osv record GHSA-m3c6-2p7h-cfr3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-62182 Advisory: KubeEdge: ConfigUpdateJob updateFields enables remote shell injection and code execution on edge nodes IDs: CVE-2026-62182, GHSA-m3c6-2p7h-cfr3 Record: https://patchnext.com/advisories/cve-2026-62182 (revision 3, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kubeedge/kubeedge 1.23.1, 1.22.2, 1.21.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kubeedge/kubeedge: affected >= 1.21.0, < 1.21.2; >= 1.22.0, < 1.22.2; >= 1.23.0, < 1.23.1; fixed in 1.21.2, 1.23.1, 1.22.2 ## Suggested inspection (read-only) - Go github.com/kubeedge/kubeedge: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kubeedge/kubeedge. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6573 (OSV record GO-2026-6573 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.21.0 =1.22.0 =1.23.0 <1.23.1 (fixed)) - Verified: https://osv.dev/vulnerability/GHSA-m3c6-2p7h-cfr3 (OSV record GHSA-m3c6-2p7h-cfr3 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.21.0 =1.22.0 =1.23.0 <1.23.1 (fixed)) - Verified: https://github.com/advisories/GHSA-m3c6-2p7h-cfr3 (GitHub-reviewed advisory GHSA-m3c6-2p7h-cfr3 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.21.0 =1.22.0 =1.23.0 <1.23.1) Commands are suggestions: review each one before running it.
Loading voting…