Skip to content

← Actionable
Critical, CVSS 9.1amended

PraisonAI: Code Injection via f-string Interpolation in Deploy API Server Generation

CVE-2026-62176GHSA-g6j7-pffp-8whg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.78), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    <= 4.6.77
    Fixed in
    4.6.78

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-61444: 0.50% estimated exploitation activity in the next 30 days; percentile 42.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2026-62176: 0.46% estimated exploitation activity in the next 30 days; percentile 39.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The deploy/api.py module generates Python server code by directly interpolating the agentsfile parameter into an f-string that is then written to a file and executed via subprocess.Popen(). An attacker who controls the agentsfile value (via CLI argument, configuration, or upstream API) can inject arbitrary Python code. Details src/praisonai/praisonai/deploy/api.py (line 80): The generated code is then executed (line 190): agentsfile is never sanitized or validated. A malicious value breaks out of the string context: The same pattern exists in deploy/docker.py (line 33) for Dockerfile generation. PoC Impact - Arbitrary code execution on the machine running the deploy command - Supply chain risk if agentsfile comes from a configuration file or CI/CD pipeline

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g6j7-pffp-8whg

  2. Revision 2 · amended ·

    Amended from osv record GHSA-g6j7-pffp-8whg

  3. Revision 1 · created ·

    Published from ghsa record GHSA-g6j7-pffp-8whg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-62176

Advisory: PraisonAI: Code Injection via f-string Interpolation in Deploy API Server Generation
IDs: CVE-2026-62176, GHSA-g6j7-pffp-8whg
Record: https://patchnext.com/advisories/cve-2026-62176 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.78. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected <= 4.6.77; fixed in 4.6.78

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g6j7-pffp-8whg (GitHub-reviewed advisory GHSA-g6j7-pffp-8whg lists affected ranges: PyPI praisonai >=0 <=4.6.77)
- Verified: https://osv.dev/vulnerability/GHSA-g6j7-pffp-8whg (OSV record GHSA-g6j7-pffp-8whg lists affected ranges: PyPI praisonai >=0 <4.6.78 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…