Crass: Deeply nested CSS blocks and functions can trigger a SystemStackError or excessive memory usage
CVE-2026-61846GHSA-6jxj-px6v-747w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (crass 1.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems crass
- Affected
- < 1.0.7
- Fixed in
- 1.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6jxj-px6v-747w lists affected ranges: RubyGems crass >=0 <1.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6jxj-px6v-747w lists affected ranges: RubyGems crass >=0 <1.0.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L · score source
- EPSS
- CVE-2026-61846: 0.49% estimated exploitation activity in the next 30 days; percentile 41.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Crass recursively parses CSS simple blocks and functions without a depth guard. An attacker-controlled value containing many deeply nested blocks can recurse until Ruby raises `SystemStackError: stack level too deep`, or can cause excessive memory usage.
Patches This is fixed in Crass 1.0.7, which adds a configurable depth limit with a conservative default.
Workarounds Add `SystemStackError` handling around Crass calls in your application. Buy more RAM.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-6jxj-px6v-747w
- Revision 1 · created ·
Published from ghsa record GHSA-6jxj-px6v-747w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-61846 Advisory: Crass: Deeply nested CSS blocks and functions can trigger a SystemStackError or excessive memory usage IDs: CVE-2026-61846, GHSA-6jxj-px6v-747w Record: https://patchnext.com/advisories/cve-2026-61846 (revision 2, source checked 30 Oct 2026, 07:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: crass 1.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems crass: affected < 1.0.7; fixed in 1.0.7 ## Suggested inspection (read-only) - RubyGems crass: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on crass. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6jxj-px6v-747w (GitHub-reviewed advisory GHSA-6jxj-px6v-747w lists affected ranges: RubyGems crass >=0 <1.0.7) - Verified: https://osv.dev/vulnerability/GHSA-6jxj-px6v-747w (OSV record GHSA-6jxj-px6v-747w lists affected ranges: RubyGems crass >=0 <1.0.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…