Skip to content

← Actionable
High, CVSS 8.7amended

code16/sharp has a stored XSS via data-html-content Sanitizer Bypass

CVE-2026-61825GHSA-vj3q-vp3g-j9c8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code16/sharp 9.22.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-61825: 0.23% estimated exploitation activity in the next 30 days; percentile 14.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The vulnerability allows an attacker to bypass the HTML sanitizer by using the data-html-content attribute in the content of a SharpEditorFormField. Patches The field must now explicitly configure SharpFormEditorField::RAWHTML in the toolbar to keep this behavior. When using the RAWHTML button, the application using code16/sharp must sanitize manually the content coming from the field. Vulnerability has been patched in version 9.22.5. Workarounds Sanitize every contents of editors manually (e.g. using Symfony/HtmlSanitizer)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vj3q-vp3g-j9c8

  2. Revision 1 · created ·

    Published from osv record GHSA-vj3q-vp3g-j9c8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61825

Advisory: code16/sharp has a stored XSS via data-html-content Sanitizer Bypass
IDs: CVE-2026-61825, GHSA-vj3q-vp3g-j9c8
Record: https://patchnext.com/advisories/cve-2026-61825 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code16/sharp 9.22.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist code16/sharp: affected < 9.22.5; fixed in 9.22.5

## Suggested inspection (read-only)
- Packagist code16/sharp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code16/sharp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vj3q-vp3g-j9c8 (OSV record GHSA-vj3q-vp3g-j9c8 lists affected ranges: Packagist code16/sharp >=0 <9.22.5 (fixed))
- Verified: https://github.com/advisories/GHSA-vj3q-vp3g-j9c8 (GitHub-reviewed advisory GHSA-vj3q-vp3g-j9c8 lists affected ranges: Packagist code16/sharp >=0 <9.22.5)

Commands are suggestions: review each one before running it.

Loading voting…