code16 Sharp vulnerable to stored XSS via iframe srcdoc Attribute
CVE-2026-61823GHSA-qxg3-46rw-79j8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (code16/sharp 9.22.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist code16/sharp
- Affected
- < 9.22.5
- Fixed in
- 9.22.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qxg3-46rw-79j8 lists affected ranges: Packagist code16/sharp >=0 <9.22.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qxg3-46rw-79j8 lists affected ranges: Packagist code16/sharp >=0 <9.22.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-61823: 0.21% estimated exploitation activity in the next 30 days; percentile 11.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Stored Cross-Site Scripting (XSS) vulnerability exists in the rich text editor due to improper sanitization of the srcdoc attribute on <iframe elements. While the underlying Symfony HtmlSanitizer correctly HTML-encodes special characters inside the attribute value (e.g., converting <script to <script>), the HTML specification mandates that browsers automatically decode HTML entities inside attribute values before processing them. As a result, any encoded JavaScript inside a srcdoc attribute is evaluated and executed as live HTML/JS in the context of the iframe when the page is rendered. An attacker with permissions to edit an Editor field can inject malicious scripts to target other users viewing the content. Potential impacts include: - Session Hijacking (stealing admin session cookies via document.cookie) - Account Takeover & Privilege Escalation (e.g., a low-privileged editor triggering actions as an Administrator) - Admin panel data theft Patches The vulnerability…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qxg3-46rw-79j8
- Revision 1 · created ·
Published from osv record GHSA-qxg3-46rw-79j8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-61823 Advisory: code16 Sharp vulnerable to stored XSS via iframe srcdoc Attribute IDs: CVE-2026-61823, GHSA-qxg3-46rw-79j8 Record: https://patchnext.com/advisories/cve-2026-61823 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: code16/sharp 9.22.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist code16/sharp: affected < 9.22.5; fixed in 9.22.5 ## Suggested inspection (read-only) - Packagist code16/sharp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on code16/sharp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qxg3-46rw-79j8 (OSV record GHSA-qxg3-46rw-79j8 lists affected ranges: Packagist code16/sharp >=0 <9.22.5 (fixed)) - Verified: https://github.com/advisories/GHSA-qxg3-46rw-79j8 (GitHub-reviewed advisory GHSA-qxg3-46rw-79j8 lists affected ranges: Packagist code16/sharp >=0 <9.22.5) Commands are suggestions: review each one before running it.
Loading voting…