Skip to content

← Actionable
Medium, CVSS 6.3

Snipe-IT: Stored DOM XSS via table selected-count IDs

CVE-2026-61807GHSA-c8qc-wf67-342w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (snipe/snipe-it 8.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2026-61807: 0.21% estimated exploitation activity in the next 30 days; percentile 11.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The table component derives data-selected-count-id from the component $name value. On manufacturer and supplier detail pages, stored manufacturer or supplier names are passed into affected table components as that name value. The client-side JavaScript later reads the browser-decoded data-selected-count-id, uses it as a selector, and concatenates countId.substring(1) directly into an HTML string passed to jQuery .after(). Affected commit: b224cc636c6780386e3f73f03d1171f52ab4c37a Example payload for a manufacturer or supplier name: x[foo="<svg/onload=alert(1)"] The issue appears to involve the following flow: Stored supplier/manufacturer name - table component data-selected-count-id - browser decodes the attribute - JavaScript reads countId - countId is used as a selector - countId.substring(1) is concatenated into HTML - jQuery .after() inserts attacker-controlled markup - JavaScript executes in the victim's browser Potential impact includes arbitrary JavaScript execution in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c8qc-wf67-342w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61807

Advisory: Snipe-IT: Stored DOM XSS via table selected-count IDs
IDs: CVE-2026-61807, GHSA-c8qc-wf67-342w
Record: https://patchnext.com/advisories/cve-2026-61807 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: snipe/snipe-it 8.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist snipe/snipe-it: affected < 8.6.2; fixed in 8.6.2

## Suggested inspection (read-only)
- Packagist snipe/snipe-it: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on snipe/snipe-it.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c8qc-wf67-342w (GitHub-reviewed advisory GHSA-c8qc-wf67-342w lists affected ranges: Packagist snipe/snipe-it >=0 <8.6.2)

Commands are suggestions: review each one before running it.

Loading voting…