github.com/moby/sys/user has a possible DoS via unbounded parsing of user and group database files
CVE-2026-61801GHSA-mjcv-p78q-w5fw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/moby/sys/user 0.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 0.4.0
- Fixed in
- 0.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6686 lists affected ranges: Go github.com/moby/sys/user >=0 <0.4.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mjcv-p78q-w5fw lists affected ranges: Go github.com/moby/sys/user >=0 <0.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mjcv-p78q-w5fw lists affected ranges: Go github.com/moby/sys/user >=0 <=0.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-61801: 0.12% estimated exploitation activity in the next 30 days; percentile 1.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A denial-of-service (DoS) vulnerability exists in github.com/moby/sys/user before v0.4.1 when parsing specially crafted user or group database files. An attacker able to supply a malicious /etc/passwd or /etc/group-style file may cause excessive memory consumption, potentially resulting in process termination due to Out Of Memory (OOM) conditions. This issue is related to containerd [CVE-2026-47262] / GHSA-jpcc-p29g-p8mq, which describes one practical exploitation path through processing untrusted container image content. Applications using github.com/moby/sys/user to parse untrusted user or group database files may be similarly affected. Impact github.com/moby/sys/user versions before v0.4.1 do not place sufficient limits on entries while parsing user and group database files. A specially crafted file may cause excessive memory consumption, potentially leading to process termination due to Out Of Memory (OOM) conditions. Applications that use github.com/moby/sys/user to parse…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mjcv-p78q-w5fw
- Revision 2 · amended ·
Amended from osv record GO-2026-6686
- Revision 1 · created ·
Published from osv record GHSA-mjcv-p78q-w5fw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-61801 Advisory: github.com/moby/sys/user has a possible DoS via unbounded parsing of user and group database files IDs: CVE-2026-61801, GHSA-mjcv-p78q-w5fw Record: https://patchnext.com/advisories/cve-2026-61801 (revision 3, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/moby/sys/user 0.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/moby/sys/user: affected <= 0.4.0; fixed in 0.4.1 ## Suggested inspection (read-only) - Go github.com/moby/sys/user: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/moby/sys/user. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6686 (OSV record GO-2026-6686 lists affected ranges: Go github.com/moby/sys/user >=0 <0.4.1 (fixed)) - Verified: https://osv.dev/vulnerability/GHSA-mjcv-p78q-w5fw (OSV record GHSA-mjcv-p78q-w5fw lists affected ranges: Go github.com/moby/sys/user >=0 <0.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-mjcv-p78q-w5fw (GitHub-reviewed advisory GHSA-mjcv-p78q-w5fw lists affected ranges: Go github.com/moby/sys/user >=0 <=0.4.0) Commands are suggestions: review each one before running it.
Loading voting…