Skip to content

← Actionable
High, CVSS 7.4amended

@bytebase/dbhub's read-only mode does not prevent database writes

CVE-2026-61788GHSA-mwwr-p57h-56pf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@bytebase/dbhub 0.22.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-61788: 0.40% estimated exploitation activity in the next 30 days; percentile 34.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Setting readonly = true on the executesql tool does not make the connection read-only. The connectors are written to set PostgreSQL defaulttransactionreadonly=on (and open SQLite in readOnly mode), but that code is gated on a config value that is never populated, so it never runs. The only thing left enforcing read-only is a classifier that inspects the first keyword of each statement. Any SELECT that writes or has side effects through a function call passes it. With an ordinary role this allows sequence tampering; with a privileged role it allows writing arbitrary files on the server (loexport), reading arbitrary host files (pgreadfile), and remote code execution (dblink + COPY ... TO PROGRAM). The HTTP transport is unauthenticated and binds to 0.0.0.0 by default, so this is reachable by any network caller of /mcp. Details Two problems combine. 1. The database-level read-only control is dead code. PostgresConnector.connect() only enables it when config.readonly is truthy…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mwwr-p57h-56pf

  2. Revision 2 · amended ·

    Amended from osv record GHSA-mwwr-p57h-56pf

  3. Revision 1 · created ·

    Published from ghsa record GHSA-mwwr-p57h-56pf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61788

Advisory: @bytebase/dbhub's read-only mode does not prevent database writes
IDs: CVE-2026-61788, GHSA-mwwr-p57h-56pf
Record: https://patchnext.com/advisories/cve-2026-61788 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @bytebase/dbhub 0.22.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @bytebase/dbhub: affected < 0.22.6; fixed in 0.22.6

## Suggested inspection (read-only)
- `npm ls @bytebase/dbhub --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @bytebase/dbhub.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mwwr-p57h-56pf (GitHub-reviewed advisory GHSA-mwwr-p57h-56pf lists affected ranges: npm @bytebase/dbhub >=0 <0.22.6)
- Verified: https://osv.dev/vulnerability/GHSA-mwwr-p57h-56pf (OSV record GHSA-mwwr-p57h-56pf lists affected ranges: npm @bytebase/dbhub >=0 <0.22.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…