@rsdoctor/rspack-plugin has Unauthenticated HTTP API that Exposes Project Source Code and Build Metadata
CVE-2026-61782GHSA-jmg2-rcxh-w8q3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@rsdoctor/rspack-plugin 1.5.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 1.5.15
- Fixed in
- 1.5.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jmg2-rcxh-w8q3 lists affected ranges: npm @rsdoctor/rspack-plugin >=0 <=1.5.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jmg2-rcxh-w8q3 lists affected ranges: npm @rsdoctor/rspack-plugin >=0 <1.5.16 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-61782: 0.43% estimated exploitation activity in the next 30 days; percentile 37.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The default Rsdoctor report HTTP server started by @rsdoctor/rspack-plugin binds to all network interfaces (0.0.0.0) and serves a POST /api/data/key endpoint with no authentication and wildcard CORS (Access-Control-Allow-Origin: ). Any network-adjacent or remote attacker can send a single unauthenticated request to retrieve the full source code of all compiled JavaScript modules (moduleCodeMap), serialized build configuration (configs), error details, and other sensitive build metadata. This server is enabled by default in non-CI environments, requiring no special configuration from the victim developer. Details Root cause: server binds to all interfaces with no authentication and no key allowlist. The vulnerability is composed of four independently observable defects that together create a complete unauthenticated information-disclosure path: 1. Server binds to 0.0.0.0 (all interfaces) packages/utils/src/build/server.ts:107 calls server.listen(port, callback) without a host…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jmg2-rcxh-w8q3
- Revision 2 · amended ·
Amended from osv record GHSA-jmg2-rcxh-w8q3
- Revision 1 · created ·
Published from ghsa record GHSA-jmg2-rcxh-w8q3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-61782 Advisory: @rsdoctor/rspack-plugin has Unauthenticated HTTP API that Exposes Project Source Code and Build Metadata IDs: CVE-2026-61782, GHSA-jmg2-rcxh-w8q3 Record: https://patchnext.com/advisories/cve-2026-61782 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @rsdoctor/rspack-plugin 1.5.16. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @rsdoctor/rspack-plugin: affected <= 1.5.15; fixed in 1.5.16 ## Suggested inspection (read-only) - `npm ls @rsdoctor/rspack-plugin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @rsdoctor/rspack-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jmg2-rcxh-w8q3 (GitHub-reviewed advisory GHSA-jmg2-rcxh-w8q3 lists affected ranges: npm @rsdoctor/rspack-plugin >=0 <=1.5.15) - Verified: https://osv.dev/vulnerability/GHSA-jmg2-rcxh-w8q3 (OSV record GHSA-jmg2-rcxh-w8q3 lists affected ranges: npm @rsdoctor/rspack-plugin >=0 <1.5.16 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…