Skip to content

← Actionable
Critical, CVSS 9.3amended

LightRAG is Vulnerable to Authentication Bypass: hardcoded DEFAULT_TOKEN_SECRET and public /auth-status defeat LIGHTRAG_API_KEY protection

CVE-2026-61740GHSA-f4vv-55c2-5789

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lightrag-hku 1.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-61740: 0.51% estimated exploitation activity in the next 30 days; percentile 43.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When LightRAG is deployed with LIGHTRAGAPIKEY set but AUTHACCOUNTS unset (an officially documented "API-Key authentication" mode), the X-API-Key protection can be bypassed by any remote unauthenticated attacker. The bypass does not require network contact with the victim server — an attacker can mint a valid guest JWT offline using the hardcoded DEFAULTTOKENSECRET committed in the repository and then call any endpoint guarded by Depends(combinedauth), including destructive operations such as DELETE /documents, POST /documents/upload, /documents/clearcache, and POST /query. This is distinct from the previously-fixed GHSA-mcww-4hxq-hfr3 / CVE-2026-30762, which only covered the AUTHACCOUNTS-configured case. The API-Key-only deployment profile is still fully exploitable on current main (commit 157c331, v1.4.15). Root cause Three independent issues combine: 1. lightrag/api/config.py:54 ships a hardcoded default JWT secret: 2. lightrag/api/auth.py:28-38 falls back to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-f4vv-55c2-5789

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-f4vv-55c2-5789

  4. Revision 1 · created ·

    Published from ghsa record GHSA-f4vv-55c2-5789

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61740

Advisory: LightRAG is Vulnerable to Authentication Bypass: hardcoded DEFAULT_TOKEN_SECRET and public /auth-status defeat LIGHTRAG_API_KEY protection
IDs: CVE-2026-61740, GHSA-f4vv-55c2-5789
Record: https://patchnext.com/advisories/cve-2026-61740 (revision 4, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lightrag-hku 1.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lightrag-hku: affected < 1.5.4; fixed in 1.5.4

## Suggested inspection (read-only)
- `python -m pip show lightrag-hku`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lightrag-hku.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f4vv-55c2-5789 (GitHub-reviewed advisory GHSA-f4vv-55c2-5789 lists affected ranges: PyPI lightrag-hku >=0 <1.5.4)
- Verified: https://osv.dev/vulnerability/GHSA-f4vv-55c2-5789 (OSV record GHSA-f4vv-55c2-5789 lists affected ranges: PyPI lightrag-hku >=0 <1.5.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…